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  Multi Track Recorder 
 
Introduction 
 
MeTeoR is a digital multi-track recorder designed specifically for the Pocket PC. The 
program features up to 12 tracks of high quality audio, a built in mixer and multi-effects 
processor. MeTeoR is ideally suited for creating musical compositions, and also a great 
tool for journalists and business people who need to splice and piece together voice notes, 
narration or dictation. Compositions once mixed can be exported to standard file formats 
for use on your desktop PC. 
 
Important Notes 
 
MeTeoR uses uncompressed WAV files in order to achieve its speed. Audio data is 
recorded at 44.1Kb/s (CD quality) and require large amounts of storage space. It is 
therefore recommended that you use an add-on SD/CF expansion card to store recorded 
materials. A 1GB SD card for instance will store approximately 6 hours of recordings. 
 
Another important factor is the speed of your expansion cards. The faster the card, the 
more tracks you can play at any one time. Using a high speed x133 SD card, you should 
be able to achieve approximately 10-12 simultaneous tracks without any problems. 
 
Some WM5 devices such as the Dell Axim x51v have very slow internal flash memory. 
Whilst this has its benefits in terms of being none volatile, it is much slower than 
conventional RAM. For this reason it is advisable to use high speed expansion cards 
rather than internal memory.  
 

Auto Calibration 
 
The first time you run MeTeoR, you will be 
prompted to run the Auto Calibration. This is very 
important as it ensures audio playback is synced 
with recordings. 
 
Before running the Auto Calibration please ensure 
you unplug any headphones / headsets and ensure 
the master volume is not muted. A series of 10 
high pitched beeps will be heard approx 1 second 
apart. MeTeoR times how long it takes for this 
sound to travel thought your internal speaker and 
back through the microphone. From this it can 
determine the audio latency of your device. 
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Speed Test 
 
The first time you run MeTeoR you will also be 
asked to run the speed test to ensure your device 
is fast enough to record real-time audio. This 
test will time reading and writing to the 
currently selected project folder.   
 
Once the test is complete a dialog containing 
the speed test results is displayed. If the speed 
test gives ‘poor’ for either read or write speed 
perform the test again to confirm this is the 
case. Ideally the read speed should be above 
1Mb/s and the write speed above 0.5Mb/s. If 
you are consistently seeing low values then you 
need to consider using a high speed CF/SD 
card. Low ram speeds result in audio glitches 
and poor recordings. 
 
The speed test checks the speed of the currently selected ‘Project Path’. You can change 
this path using the ‘Project Path’ option on the ‘File Menu’.  
 
You can run these tests at any time by selecting ‘Speed Test’ from the ‘Setup’ menu. 
 
 
Getting Started 
 
Before you begin using the program it is advisable to read through the following section 
in order to familiarise yourself with some of the terms and concepts which will help make 
the program easier to use. 
 
The following list contains a list of meanings for various terms used throughout this 
manual. 
 
Term Meaning 
Clip A single audio recording. A track may have one or more audio clips. 
Project A file that contains sequencing information for your sound clips. 
Audio Pool Contains all the clips available for the current project. 
Mixer A device that controls the volume and stereo positioning of clips. 
Metronome An instrument is used to indicate the exact tempo of a composition. 
Controllers Information that is used to remote control the mixer and effects. 
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Creating a Project 
 
Whenever you wish to create a new song or narration you should create a new project. A 
project simply stores information such as which audio clips to play and in what order. It 
also contains information such as volume/pan levels for each track and information 
regarding effects and their settings.  
 
To create a new project, simply select ‘New Project’ from the ‘File’ menu. You will then 
be asked for a ‘Project Folder’, which is the location you wish all recorded clips 
associated with this project to be stored.  
 
All recordings are referred to as audio ‘Clips’, and are stored in a designated ‘Project 
Folder’. This folder is often referred to as the ‘Audio Pool’, as it contains a list of all the 
clips available to your project. 
 
 
Your first Recording 
 
Once you have created a new project and specified the project folder you are ready to 
begin recording audio clips.  
 

Ensure that the ‘Track’ tab is selected at the 
bottom of the screen. You should now see all 12 
tracks displayed vertically with ‘Track 1’ selected.  
 
The selected track is designated by a red circle 
around the track number. You can select a 
different track by tapping the number of the track. 
The red circle should now appear next to the 
specified track.  
 
You now need to position the play cursor at the 
beat/bar where you wish recording to begin. To do 
this simply touch the screen and drag the vertical 
red play cursor to the desired position.  
 
Finally, to begin recording press the RECORD 
button on the left of the toolbar. To stop 
recording, press the STOP button. 

 
Use the REC monitor above the track numbers prior to recording to ensure you have 
sufficient volume for your recording. Once recording has started you can click the 
‘Editor’ tab to preview the recorded signal. 
 
Congratulations, you have made your first recording. 
 

Selected 
Record Track 

Record 
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Multi Track Recordings 
 
MeTeoR was specifically designed for multi-track 
recording and sequencing, but there are a few 
things you need to know in order to get the best 
out of the program.  
 
By default, when you record a clip all other clips 
are muted. If you are recording voice notes then 
this is fine, but if you are recording a passage of 
music then you may want to play along to 
previously recorded tracks.  To allow this you 
must turn off the ‘Mute Tracks During Playback’ 
option from the ‘Setup’ menu.  
 
If you disable ‘Mute Tracks During Playback’ 
then you will hear previously recorded tracks 
during the recording process. Unfortunately this 
means that if you are not wearing headphones 
then the internal microphone will also pick up 

what is being played and record this too. So if you wish to use previously recorded 
material as a guide you must be using headphones. 
 
So now you are ready to record a second track.  Simply select the track on which you 
want to record your next audio clip by tapping on the track number. The RED circle 
should appear over the track number. Position the play cursor at the desired location and 
finally press the ‘R’ button once more.  
 
 
Playing a Recording 
 
Once you have recorded one or more tracks you will want to listen to what you have 
reordered. To do this, simply press the BEGIN button on the toolbar to move the play 
cursor to the start of your composition. . Press PLAY to begin playback. 
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Mute & Solo 
 

You may occasionally want to mute a certain track whilst listening to your 
composition. You can do this by pressing the Mute button which is located next 
to the track number. When the ‘M’ button is lit, the track is muted. There may 
also be times when you wish to listen to one or more tracks in isolation. To do 

this press the ‘S’ (solo) button next to the desired track. Solo takes priority over mute 
which basically means if you have solo button selected for any track, it will be heard 
regardless of its mute status. To return to normal playback you need to turn off all the 
solo and mute buttons. 
 
 

The Metronome 
 
The metronome is used as a guide to indicate the tempo of your composition during the 
recording process. If you are recording a musical composition then you will almost 
certainly need to use the metronome as a guide when laying down your first track.  
 

Select the ‘Metronome Setup’ option from the 
‘Setup’ menu. This will display the following 
dialog. 
 
To use the metronome you should: 
 
a) Select ‘Enable Metronome’ to turn the 
metronome on. 
 
b) Set the tempo dial to the desired BPM setting. 
 
c) Select the type of sound, ‘Click’ or ‘Beep’. 
 
d) Select the desired metronome volume. 
 
e) Press OK to exit the dialog. 
 
 

 
When you begin recording you should now hear the metronome. The metronome setup 
screen also allows you to specify a count-in, which sounds the metronome for a selected 
number of bars before recording begins. You need to make sure you tick the ‘Enable 
Count-In’ to use this feature. If you enable the count-in and disable the metronome, you 
will only hear the metronome during the count in. The metronome will remain silent 
during recording. 
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The Track Editor 
 
The track editor screen is used to build your composition by positioning audio clips on 
the 12 available tracks. When you record a clip it is automatically placed on the selected 
track. You may want to move this to a new location or track, split it into multiple pieces, 
or create duplicates of the same clip etc. All this can be done using the edit track screen. 
 

You may find it easier to edit your 
compositions in landscape mode. (not 
available to square screen devices). 
 
To change to landscape mode select 
‘Landscape Mode’ from the ‘Setup’ 
menu. 
 
 
 
 
 
 
 

 
Positioning a Clip 
 
You can move a clip by simply dragging the clip using your stylus to its new location. 
You can also use this method to move multiple clips at the same time. To do this you 
simply select a group of clips using the touch pen (selected clips will have a RED 
border). To remove the selection simply tap anywhere on a track that doesn’t contain a 
clip or select ‘Remove Selection’ from the ‘Edit’ menu. 
 
Snap 
  
When dragging clips you will notice that they snap to the beat. You can change this snap 
value using the combo box at the top right of the display. You can snap to a BAR, a 
BEAT or a fraction of a BEAT. 
 
Multiple Clip Selection 
 
When working with audio clips there are times when you need to perform operations on a 
selection of clip(s). Simply tapping the stylus on a clip selects that clip, but you can select 
as many clips as you like using this method (A selected clip has a RED border). To 
remove the selection, simply tap the stylus on an area of the track area that doesn’t 
contain a clip. Alternatively use the ‘Remove Selection’ from the ‘Edit’ menu. To select 
all clips in the project use the ‘Select All’ option from the ‘Edit’ menu. 
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Dividing Clips 
 
Once you have recorded a clip you may want to tidy things up by deleting part of the 
recording or chopping the recording into multiple pieces.  If you have used the 
metronome during recording then you will most likely want to divide clips at BEAT 
intervals. To do this ensure ‘1’ is selected from the ‘Snap’ combo box (top right). Now 
position the play cursor to the position on the timeline that you wish the clip to be 
divided. Tap the stylus on the clip to ensure it is selected. (it’s border should turn RED). 
Now select ‘Divide Clip(s)’ from the ‘Edit’ menu. After confirming the operation you 
should now see the clip have been divided at the position of the play cursor. It is possible 
to perform this operation on more than one clip at any one time. To do this select as many 
clips as you like before picking the ‘Divide Clip(s)’ option. 
 
Clone Clips 
 
There are many instances where you may wish to have the same clips appear more than 
once in your composition. If for instance you are recording a musical score, you may 
have two or three chorus parts to your song, all containing the same clips. Of course you 
could record the chorus again, but this is wasteful of both your time and memory. By 
cloning a clip, it simply places a second reference to the same clip into the project. To 
clone one or more clips, ensure the clips are selected and then pick ‘Clone Clip(s)’ from 
the ‘Edit’ menu. 
 
Duplicating Clips 
 
If you make modifications to a clip then these modifications will occur not only on the 
clip in question, but with all cloned clips too.  To avoid this you need to create a copy of 
the clip so that when modified, it does not affect other clips in your composition.  To do 
this select the clips you wish to duplicate and select ‘Duplicate Clip(s)’ from the ‘Edit’ 
menu. 
 
Moving Multiple Clips 
 
If you want to duplicate or move a whole section of your composition you can do so 
using Cut, Copy and Paste. Simply select the clips you wish to move then select ‘Cut’ 
from the ‘Edit’ menu. Move the play cursor to the location you wish to insert the clips 
and select ‘Paste’ from the ‘Edit’ menu. This process is also useful for duplicating whole 
sections of a composition. 
 
Deleting Clips 
 
You can remove clips from you project by simply selecting the clips and choosing 
‘Delete Clip(s)’ from the ‘Edit’ menu. Clips that are deleted from the project will still 
remain in the Audio Pool for you to use again if you wish. To permanently delete a clip 
you must delete the clip from the Audio Pool dialog. This is covered later in the manual. 
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Inserting Clips 
 
You can insert any previously recorded clips into 
your project by selecting them from the Audio 
Pool.  
 
To do this simply select the required track, place 
the play cursor at the desired location then select 
‘Insert Clip from Audio Pool’ from the ‘Edit’ 
menu. 
 
When the ‘Insert Audio Clip’ dialog appears 
simply select the clip from the ‘Clips’ combo box.  
 
You can preview a clip by pressing the ‘Preview’ 
button. Once you are happy with your selection 
press the ‘Insert’ button to add the clip to your 
project.   
 
 

 
Please Note: Inserted clips are automatically quantized to the nearest snap setting. 
 
You may have noticed that in the above example the clip had a description, and there was 
a group combo box.  By default all clips that are recorded are given a 3 digit 
identification number, which isn’t very descriptive. You will see later how you can give 
assign descriptions to your clips and even group them for easy retrieval.  
 
It is also possible to import WAV files into the Audio Pool and once there they can be 
added to your project using the ‘Insert Audio Clip’ dialog. 
 
 
Saving and Loading Compositions  
 
Meteor allows you to save your compositions in one of two formats, either as a project 
file or as a bundle (covered later in this manual). A project file stores information such as 
sequencing data (which clips are played and in what order), effects and mixer settings. 
Projects contain no sample data and rely on your Project Path to be correctly set in order 
to access sample data. 
 
To save a composition, select the ‘Save Project’ option from the ‘File’ menu.  You will 
be prompted for a file name and location to save the project file. After confirming the file 
name your composition will be saved.  
 
To load a previously saved project, select ‘Load Project’ from the ‘File’ menu. 
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Quantizing Clips 
 
Every time you record a clip, its start time is automatically adjusted to the current snap 
setting (defined by the top right drop down list of the ‘Track’ window). Once you have 
finished recording you can drag the clip to a new location but it will only move in steps 
defined by the current snap setting. This process is often referred to as quantizing, and is 
performed automatically so that you don’t have to worry about aligning clips.  
 
You can also quantize selected clips manually using the ‘Quantize Clip(s)’ option from 
the ‘Edit’ menu. In order to use this option you should first select one or more clips you 
wish to quantize. To quantize the whole song choose ‘Select All’ from the ‘Edit’ menu. 
 
Now you need to specify a quantize setting from the ‘Snap’ box. If you select ‘1’ beat 
then all the selected clips will be repositioned so that they start at the nearest beat. If you 
select ‘BAR’ then all clips are positioned so they start at the nearest bar. 
 
Finally select ‘Quantize Clip(s)’ from the ‘Edit’ menu. 
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The Audio Pool 
 
The audio pool holds all the clips that have been recorded since you started the current 
project. As mentioned previously clips deleted from the project are still visible in the 
audio pool. To permanently delete a clip you need to do this from the audio pool dialog.   
 
Please Note: The location of the Audio Pool is specified whenever you create a new 
project, you can however change it’s location at any time using the ‘Project Folder’ 
option on the ‘File’ menu. 
 
Selecting ‘Audio Pool’ from the ‘File’ menu displays the ‘Audio Pool’ dialog. 
 

The audio pool dialog is used to 
manage the clips used in your project. 
It allows you to add labels to various 
clips and assign them to a sample 
group which helps find clips at a later 
date. 
 
The audio pool also allows you to 
import samples from other packages 
so long as they are in the required 
format. 
 
 
 

 
Previewing Clips 
 
You can preview a clip at any time by selecting the clip from the list and pressing the 
Preview button. The clip will continue to play until you preview another clip or exit the 
dialog. 
 
Deleting Clips 
 
To permanently delete a clip, select the clip from the list and press the ‘Delete’ button.  
You will be asked to confirm your selection after which the clip is deleted. If you delete a 
clip that is in use in the current project it will also be deleted from the project. 
 
Delete All Clips 
 
This option permanently deletes all clips in the audio pool and the current project. This is 
very useful if you need to start your project from scratch. 
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Tidy 
 
Once your composition is complete you may find that you have many clips in your Audio 
Pool that you didn’t use in your final project. The ‘Tidy’ button permanently deletes all 
clips from the Audio Pool that are not referenced by the current project.  
 
Please Note: Be careful to specify a different project folder for each composition 
otherwise this could delete samples that are used in other compositions. 
 
Importing Clip(s) 
 
This option is used to import WAV files into the Audio Pool. The imported file must be 
of a specific format in order to be imported correctly (Please ensure the files are 44Khz, 8 
or 16bit, mono or stereo WAV files). 
 
You can use multiple select to import as many clips as you like, but please be aware that 
there is a physical limit of 999 clips per Audio Pool. This should be more than enough to 
meet your needs for a single composition. 
 
Labelling a Clip 
 
You can assign a more meaningful description to a clip using the ‘Label’ button.  

 
Select a clip from the list and press 
the ‘Label’ button. A dialog will 
appear allowing you to enter up to 32 
characters for the description. 
 
The clip description can be displayed 
in the track window by selecting the 
‘Show Clip Labels’ from the ‘Setup’ 
menu. 
 
As well as labelling the clip you can 
also assign the clip to one of several 
categories. These categories are used 
handy for grouping clips both in the 

Audio Pool, and in the ‘Insert Audio Clip’ dialogs. To assign a clip to a specific group 
select the clip from the list and then press the ‘File In’ button. A dialog will then be 
displayed allowing you to choose a category from a drop down list. Press ‘OK’ to file the 
clip in the specified group or ‘Cancel’ to exit the dialog. 
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The Mixer 
 
The mixer is used to control the respective volume of each track, its stereo positioning 
and the effects applied to it. The mixer consists of 12 sets of controls, one for each track 
plus a master volume and master effects options. 
 

 
 
 
The example image above shows the various parts of the mixer.  
 
The ‘Pan Control’ is used to position the sound either to the left or right speaker.  
 
The ‘Track Fader’ is used to adjust the volume of a particular track so that it sounds 
correct in the mix. If you hear distortion or clipping and a tracks peak meter is constantly 
in the red, try lowering the fader for that track. 
 
The ‘Mute’ button allows you to temporarily remove a track from the mix. You can mute 
as many tracks as you like. 
 
The ‘Solo’ button allows you to preview a track in isolation. Selecting the ‘Solo’ button 
mutes all other tracks that don’t have ‘Solo’ selected. You can solo more than one track 
at a time. Solo takes priority over mute, so if solo is selected on a particular track you will 
hear that track regardless of the start of the mute button. 
 
You can reset the pan and fader settings at any time using the ‘Reset Pan and Fader’ 
option from the ‘Edit’ menu. To completely reset the mixer removing all effects and the 
mute/solo buttons you can select the ‘Reset Mixer’ option from the same menu. 
 
If you find that all tracks are too high in the mix you can move all faders at the same time 
by using the ‘Modify All Faders’ option from the ‘Edit’ menu. This allows you to 
increase or reduce all faders by a specified percentage or decibel value. 
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Adding Effects 
 
MeTeoR includes various effects that can be used to enhance your recordings. Using 
effects consumes lots of CPU power so it is best to add the effects once all recording is 
complete. Effects include Chorus, Reverb, Digital Delay, Filter Factory, Pitch Shift, 
Phaser, Tremolo, Equalizer and Tone Boost.  
 
MeTeoR has the different methods of implementing effects, ‘Aux Send’ effects, ‘Insert’ 
effects and ‘Record Insert’ effects.  The way in which you use these effects is totally 
down to personal choice but it is highly recommended that you use Insert effects 
sparingly as these can consume more CPU than Aux Send effects. 
 
Insert effects apply to a single track.  You can have up to three simultaneous insert effects 
on a track at any one time (but it is not recommended).  Insert effects are best suited for 
effects that change the tonal quality of a sound, such as an equaliser or a filter. 
 
Aux Send effects are global to all tracks, and you can define up to 3 which can be active 
at any time. If for instance you wish to add reverb to more than one track it is advisable to 
define one global reverb, and then divert part of each track through the reverb using Aux 
Sends. 
 
Aux Send Effects 
 
You can define up to 3 global Aux Send effects by clicking on the Aux FX tab at the 
bottom of the screen. 

 
The left most drop down list allows you to specify 
which Aux Send you are working with. If you 
select ‘Aux Send 1, 2 or 3’ from this list you will 
see that the right drop down list initially says 
‘None’ meaning no effects are assigned.  
 
If you select ‘Digital Reverb’ from the right list it 
will assign this effect to the ‘Aux Send’ selected 
in the left list. Once the controls for the reverb 
appear you can configure the effect as required. 
 
Now you have defined a global effect you need to 
tell the mixer how much of each track to divert 
through the effect.  
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Suppose you wish to add reverb to audio clips on track 1.  To do this you need to select 
one of the ‘E’ (Effects) button for track 1 from mixer screen. This will display an Aux 
Send dialog which allows you to change the Aux Send for each of the 3 global effects. 
 

This image shows the Aux Sends dialog for 
channel 1, which shows 2 global effects assigned. 
 
The ‘E’ (Effects) buttons next to each of the 
effects allow you to turn an effect on or off. This 
is handy if you wish to preview a track without 
effects. 
 
Normally this is all you need to do to assign Insert 
effects. There is however one other option that 
allows you can specify how much of the effect is 
returned from the insert effects to the mixer. 
Generally the default settings will be fine for most 
compositions, but you can modify these settings 
yourself by simply select the ‘E’ effects button on 
the ‘Master’ track of the ‘Mixer’. This displays 
the Aux Return dialog which allows you to 
modify the return level for each of the 3 effects. 

Again there is an effect enable switch next to each effect. Disabling the effect from this 
dialog removes the effect from all tracks.  
 
 
All effects have what we call a peak meter which monitors the effects input to ensure it 
doesn’t exceed the maximum permitted input level. If you see the red peak light flashing 
for a particular effect then you need to reduce the Aux Send levels for that effect. You 
can always increase the Aux Return level to compensate. 
 
 
Record Insert Effects 
 
‘Record Insert’ effects are useful for adding effects to your recordings rather than the 
effect being applied during playback. This saves on CPU load and frees up resources for 
other effects. 
  
You can add a ‘Record Insert Effect’ in the same was as you add an ‘Aux Send Effect’ 
using the options on the ‘Aux FX’ tab (See Aux Send Effects for details). 
 
Effects are generally saved as part of your project. The one notable exception to this is 
Record Insert effects which are saved as part of your program preferences. This means 
that these effects are loaded each time you run the program.  
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Insert Effects. 
 
You can have up to 3 Insert effects per track, although it is best to limit these to a handful 
across your whole composition.  To add an ‘Insert Effect’, select one of the ‘I’ (insert) 
buttons from the ‘Mixer’. The ‘Insert Effect’ dialog will now be displayed for the 
selected track. This dialog works in a similar manner to the ‘Aux Effects’ dialog, where 
you select ‘Insert 1, 2, or 3’ from the left drop down list, then assign an effect using the 
right drop down list.. 
 

This is an image of the ‘Insert 
Effects’ dialog with a 7 Band Graphic 
Equalizer assigned to ‘Insert 1’. 
 
Please note that this ‘I’ (insert) button 
in this dialog must be enabled for the 
effect to be audible. You can also use 
this button to disable an effect 
without actually deleting the effect.. 
When the button is lit the effect is on. 
 
 
 
 

 
All ‘Insert’ effects have two extra parameters, an ‘Input Level’ and a ‘Mix Level’. The 
Input Level is used to prevent signal clipping. If the RED peak light is glowing then you 
need to reduce the input level. The Mix level controls the amount of effect applied to the 
track against the dry signal. Effects that control tone such as the Equaliser, Tone Boost 
and Filter Factory generally have the mix set to full. 
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Mixdown 
 
MeTeoR allows you to play up to 12 simultaneous tracks (CPU and RAM speed 
permitting). There maybe times when you want to use more than 12 tracks, and the way 
you do this is using the Mixdown facility. This allows you to compress several tracks 
down into a pair of stereo tracks (one for the left channel and one for the right). 
 

To create a midtown you should first ‘Mute’ all 
the tracks you don’t want to appear in the final 
output. Select the ‘Mixdown’ option from the 
‘Edit’ menu and when the dialog appears choose 
the two tracks which are to accept the left and 
right channels of the resulting mix.   
 
If you are short of tracks you can assign both 
channels to the same track, and then move them 
after the operation is complete. 
 
The dialog to the left shows the left channel 
assigned to track 8 and the right channel assigned 
to track 9. 
 
 
 
 
 

 
 
Voice Notes and Dictation 
 
So far we have discussed the creation of compositions using the musical notation of time 
which uses beats and bars. If you are using MeTeoR to record voice notes then it makes 
more sense for the Timeline to display hours, minutes and seconds. You can turn off 
‘Bars and Beats’ mode using the option on the ‘Setup’ menu.  
 
It is best to select this mode before you start recording clips as this option imposes a 
120BPM tempo which cannot be changed. If you’ve already recorded clips at anything 
other than 120BPM then selecting this mode will affect the timing of your composition. 
 
We use 120BPM because it corresponds to seconds when using the metronome. 
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Editing Clips 
 
Once you have recorded a clip you can load the clip into the sample editor. You can do 
this in one of two ways, either double tap on the clip, or click on the Editor tab and select 
the sample from the left most drop down list. 
 
NOTE: You can only edit samples that are part of your project.  
 

Using the sample editor you can perform a 
number of operations on the sample as well as 
apply effects. 
 
The ‘Edit’ menu contains a list of such operations 
which will be discussed below.  
 
As a general rule, if you select part of a clip, only 
that part will be affected. If there is no selection, 
the whole clip will be affected. 
 
When editing sections of a clip, you may need to 
change the ‘snap’ value which is available from 
the drop down list at the top right of the screen.  
 
‘Cut’, ‘Copy’ and ‘Paste’ operations work as 
expected allowing you to remove or move 
sections of a recording. 

 
‘Fade In’ and ‘Fade Out’ should be used with a selection; you can use these options to 
fade the beginning and ends of clips. 
 
‘Clear’ simply clears a section of a clip so that no sound can be heard. This is handy if 
you have nasty clicks or noise at the start or end of your recordings. 
 
‘Insert Space’ is used to insert a blank section into the current clip.  This is useful for 
padding the end of a sample before adding effects like Reverb or Digital Echo. 
 
‘Reverse’ simply causes a section or the whole clip to be reversed so that the sound plays 
backwards. 
 
‘Gain’ can be used to modify the volume of a sample by a specified amount. You can 
raise or lower the volume by a specified dB value or percentage. 
 
‘Normalise’ can be used to ensure all your clips are of similar volume.  When this option 
is selected you will be asked to specify the maximum peak volume for your clip. The 
volume of your clip will then be adjusted accordingly. 
 

Clip To 
Edit 
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‘Remove DC Offset’. DC offset is a nasty little component of many digital audio signals 
that, while often inaudible, can add to the noise floor of your project. At worst, DC offset 
can result in an audible "click" on the beginning or end of an audio clip that has been 
edited. You can see DC offset by zooming in on a view of a waveform. If the clip's zero-
crossing line (the place where the waveform crosses from positive to negative voltage or 
vice versa) is actually not at zero, but higher or lower, you've got DC offset. If you hear 
clicks or experience low-level distortion you can check for DC offset by recording a few 
seconds of silence. If the resulting waveform appears above or below the zero line, there's 
probably DC offset. Selecting this option removes the DC offset. 
 
‘Time Stretch’ is used to lengthen or shorten a recording without changing the pitch. This 
is handy if you have recorded clips and want to change your projects tempo from say 120 
to 140 bpm. This works well on small tempo changes but not so well in extreme cases. 
When using this option you can specify a change using time,. tempo or beats and bars. 
 
The ‘Effects’ option allows you to add an effect to part or the entire clip being edited.  
 

This image shows the apply effect dialog which is 
displayed when one of the options is selected 
from the ‘Effects’ submenu. 
 
This dialog is similar to the ‘Insert Effects’ dialog 
with two extra buttons, the preview and bypass 
buttons. 
 
The ‘Preview’ button can be used to hear what the 
clip would sound like if the effect were applied. 
 
The ‘Bypass’ button can be used to compare the 
effected sound against the dry (none effected) 
sound. 
 
Press ‘Apply’ to make these changes and exit the 
dialog. 
 

 
Finally, ‘Label Clip’ can be used to assign a 32 character description to the current 
sample. This is very handy with large compositions where it’s difficult to keep track of 
samples. 
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Controllers 
 
As you’ve already discovered, the mixer gives you control over the volume and stereo 
positioning of each track, but what if you want to change settings part way through your 
composition. You may for instance want to pan a track from left to right or fade in a 
sample over several bars.  This and much more can be accomplished using controllers. 
 
Controllers are edited on a track by track basis, and can be used not only control the 
mixer, but also various parameters of send and insert effects. 
 
To edit controllers click on the ‘Track’ tab and select ‘Controllers’ from the ‘Edit’ menu. 
 

This image displays the ‘Edit 
Controller’ dialog. As you can see the 
dialog is currently displaying the pan 
control for track 1. 
 
You can use the timeline or the clip 
lane as a guide to adding controllers.  
 
The ‘Pen’ button is selected by 
default and allows you to paint into 
the graphing area in a freehand 
fashion.  
 
 

The ‘Rubber’ icon can be used to erase controller data.  
 
The ‘Arrow head’ icon can be used to draw straight lines in the graphing area.  This 
allows you to add a series of controllers that follow the incline of the line, which make it 
easier to draw smooth ramps than the freehand pen tool. 
 
You can use the ‘Delete’ button at any time to delete all controllers for the currently 
selected ‘Track’ and ‘Controller’ type. If you want to delete all controllers within your 
composition you can do this from the Mixer by selecting ‘Delete All Controllers’ from 
the ‘Edit’ menu. 
 
Important Note: Using controllers can consume large amounts of memory so use them 
sparingly.  Rather than use a continuous block of controllers it is more processor friendly 
to space out controllers to conserve memory. For this reason controllers are saved in a 
separate file and not as part of your project. 
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Loop Points 
 
It is often useful to have a section of your composition play in a continuous loop. This 
allows you to practice a section of a song before you commit to recording, or useful when 
inserting controllers.  
 

This image shows a loop set between bars 44 and 
48.  During play mode if the play cursor hits the 
loop end marker (bar 48) it will begin playback at 
the loop start marker (bar 44). 
 
To set loop points simply drag an area in the 
timeline. Alternatively position the play cursor 
and select either ‘Loop Start’ or ‘Loop End’ from 
the ‘Edit / Loop Points’ submenu. 
 
To remove a the current loop points simply tap in 
the timeline or select ‘Clear Loop Points’ from the 
‘Edit / Loop Points’ submenu. 
 
 
 
 

 
Coloured Lanes 
 
You can’t have missed the fact all the examples in this manual show colours assigned to 
each of the 12 tracks.  You can assign a colour of your choice to a track using the popup 
colour menu. 

 
This image shows the colour menu 
which can be displayed by double 
tapping on the two digit track number 
on the left of the display. 
 
Track colours are also used in the 
mixer to easily identify a track. You 
may for instance want to assign a 
particular colour to vocal tracks, and 
another to lead guitar etc. 
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Bundles 
 
You may find from time to time you want to back up your project and any samples 
associated with it since a project contains no sample data.  MeTeoR allows you to save 
everything needed to restore your composition into a single file called a bundle. Bundles 
can be very large so it is recommended that you backup to a CD/CF card. 
 
To save a bundle you first have to load a project, then select ‘Save Bundle’ from the 
‘File’ menu. Once the ‘Save Bundle’ dialog appears press the ‘Edit’ button to enter a file 
name for the bundle. Browse to the folder to which you wish to save the file then press 
OK when done. 
 
NOTE: Only clips referenced by your project will be saved to the bundle.  
 
To Load a bundle select ‘Load Bundle’ from the ‘File’ menu. Select the bundle you wish 
to expand and press OK. You will then be asked for the location to expand the clips used 
in your composition. At this point you can specify the name of an existing folder or 
create a new folder of your choice. The folder chosen will become the selected project 
path (audio pool) for the project. 
 
 

Setup Options 
 
The ‘Setup’ menu contains various options are explained below: 

 
‘Metronome’ – Turns the metronome 
on/off. To change metronome settings 
please use the ‘Metronome Setup’ 
option from the same menu. 
 
‘Count-In’ – Enables the metronome 
to sound for a specified number of 
bars before recording begins. This is 
useful for cueing recording. To 
change the number of bars or tempo, 
use the ‘Metronome Setup’ option. 
 
 
 

 
‘Follow Cursor’ – By default this option is enabled and causes the screen to scroll once 
the play cursor goes off screen. This ensures that you can visually see the clips that are 
playing or about to play. You may however want to disable this feature to allow editing 
during playback. 
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‘Record Monitor’ – This option enables the microphone so you can monitor the input 
sound level before you start recording. The record meter appears in the ‘Track’ tab to the 
left of the timeline. 
 
‘Bars and Beats’ – By default this option is enabled and is used to specify whether the 
timeline is to count time or beats and bars.  If this item is disabled then the cursor time is 
displayed as hours, minutes and seconds and the temp is fixed to 120bmp.  
 
‘Mute Tracks During Record’ – When this option is enabled all tracks are muted during 
playback. If you are using a pair of headphones you can turn this option off and hear pre-
recorded tracks playback during the recording process. If you turn this option off and are 
not using headphones then there is a likely chance that tracks being played will picked up 
by the microphone during recording. 
 
‘Landscape Mode‘ – If you are using a PDA with a resolution of 240x320 you can flip 
the screen through 90 degrees into landscape mode. This gives much a better editing area 
for constructing your compositions. 
 
 

Exporting Files 
 
Once you have completed your masterpiece you will want to convert it to a standard 
format that can be played from your desktop computer.  
 
MeTeoR allows you to export to both WAV and MP3 format.  This process can be slow 
and is probably best done with your PDA sat in its docking station. 
 
To export either WAV or MP3 format simply pick the desired option from the ‘File’ 
menu and follow the prompts. Exported files, especially WAV files are very large in size 
so please ensure the selected storage device has plenty of free storage space. 
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Troubleshooting 
 
The following list of problems and solutions has been compiled to help solve any 
problems you may have encountered whilst using ‘MeTeoR’. 
 
Problem Solution 
My recordings don’t synchronize with 
properly with other pre-recorded material. 
Why is this? 

You need to run the Auto Configuration 
Wizard in order to calibrate your PPC. 

I keep getting ‘Calibration Failed’ when 
attempting to calibrate my device. What am 
I doing wrong? 

You need to unplug any headphones and 
ensure your PPC isn’t muted. If problems 
persist try setting the volume to around ¾ 
of the maximum setting. You should hear a 
series of 10 high pitched clicks emitted 
from the internal speaker of your PPC. 

I cannot position my recorded clips on 
anything other than a beat boundary, why 
is this? 

You need to adjust the ‘Snap’ setting. The 
snap setting is the top right drop down list 
in track and editor modes. You can reduce 
the snap to as little as 1/64th of a beat. 

When I record a clip the play cursor seems 
very jerky. 

Recording takes priority over screen update 
so if you are stressing your CPU this will 
manifest itself in slow screen updates. To 
help get round this problem check that you 
have no other memory / CPU hogging 
programs in memory.  Try soft resetting 
your Pocket PC. Turn on the ‘Mute Tracks 
During Record’ option from the ‘Setup’ 
menu. If all else fails the problem could 
simply be due to slow memory or SD/CF 
cards. 

Editing operations seem to be very slow. MeTeoR stores its data files in RAW 
uncompressed WAV format which can be 
extremely large.  Editing a file of several 
minutes in length will take some time to 
process. Just copying a file of several 
megabytes can take a minute or two, 
especially with WM5 devices. 

Recording aborts with an Out of Memory 
error despite having a large SD card 
inserted in my PPC. 

The error means that there is insufficient 
storage memory in the specified Project 
Folder (audio pool). Chances are you have 
not told MeTeoR to place its Audio Pool 
on the ‘SD Card’. To do this select ‘Project 
Folder’ from the ‘File’ menu and browse to 
your ‘\SD Card’ folder. 
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Resolving Audio Problems 
 
Whilst every effort has been made to test compatibility across a range of devices, you 
may find that you can fine tune MeTeoR in order to squeeze a little more performance.  
 
A word of caution, this isn’t for the faint hearted as it involves manually editing the 
configuration files. The configuration file PREFS.XML is stored in the installation folder 
and created after the program is run for the first time. If you mess up the configuration 
file then the program may fail to run. If this happens, simply delete the file and it will be 
re-created with default settings next time MeTeoR is run. 
 
The PREFS.XML file is in standard XML format so you will require an external text 
editor in order to make changes to this file. If you are unfamiliar with XML format or 
don’t know how to edit the file then it is advisable that you leave well alone. 
 
You should ensure that you only change features documented below as changing 
undocumented option may result in unexpected program operation or even data loss. 
 
 
Modifying the Audio File Cache Settings 
 
If you are having problems with stuttering audio during playback or recording then you 
can try adjusting the following options:- 
 
<AudioCache ReadCacheSize="32768" WriteCacheSize="65536"/> 
 
The ‘ReadCacheSize’ specifies the size of the read ahead cache. Whenever MeTeoR 
reads a block of audio data from a file it always reads blocks of specified size. By default 
this is 32K.  
 
The ‘WriteCacheSize’ is used to tell Meteor how much data to write to SD/CF card at 
any one time. Writing small blocks of data to file can often be slower than writing one 
larger block. This is especially true of CD/CF cards that may need to erase blocks of 
storage on the fly. 
 
 
Changing the Audio Buffer Size 
 
Your Pocket PCs audio device needs a constant steady stream of audio data in order to 
maintain glitch free playback. In order to achieve this Meteor defines a number of audio 
buffers, each of a default size of 2K (2048 bytes). These buffers are continually filled in 
rotation so that the audio device is never wanting for data.  
 
In theory the default 32 buffers of 2K in size ensure that there is at least 64K of data 
(equivalent to approx 1.48 seconds of audio at 44.1Kb/s) is available to the audio device. 
This means that so long as MeTeoR isn’t interrupted for longer than 1.48 seconds there 
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should be sufficient data to avoid audio glitches. Some slower CF/SD cards however are 
so slow at writing/erasing data that it can often take a second or two to achieve this. 
WM5 devices also have something called a memory compaction thread which can also 
interrupt a program for lengthy periods of time. 
 
So to avoid these problems we define an ‘AudioBufferSize’ and an ‘AudioBufferCount’ 
as can be seen in the line below. 
 
<Settings AudioBufferSize="2048" AudioBufferCount="32"…/> 
 
By default the buffer size is 2048 bytes or 2K. Increasing this value may help take some 
of the stress off the program, but will result in a higher audio latency.  Decreasing this 
value will improve audio latency.  
 
Values for ‘AudioBufferSize’ should range from 512 to 4096 in steps of 128. 
 
The default number of buffers specified by ‘AudioBufferCount’ is 32. Acceptable values 
are in the range 4-64. 
 
Please Note: After making modifications to either ‘AudioBufferSize’ or 
‘AudioBufferCount’ you must run the audio calibration again in order to set the correct 
latency for your system. 
 
 
 

Minimum Hardware Requirements 
 
MeTeoR is a very demanding application which needs to processes huge amounts of data 
in real time. For this reason the minimum supported CPU is 400Mhz, although we 
recommend the use of a higher speed CPU where possible.  
 
Some newer WM5 devices use flash memory rather than conventional RAM. This is 
great for data retention when your battery discharges, but the downside is that it is much 
slower than conventional random access memory.  These devices have something called 
a compaction thread which is constantly interrupting the system, stealing CPU time to 
erase blocks of memory previously owned by deleted files etc. If you own one of these 
devices then you will almost certainly need to purchase an additional high speed SD/CF 
card in order to use the program to its full potential. We recommend using high speed 
x133 cards of at least 128Mb in size. 
 
 


