# Table of Contents

- **Getting Started** ........................................................................................................................................... 4
- **Terms and Meanings** .................................................................................................................................. 6
- **Terms** ......................................................................................................................................................... 6
- **Your Audio First Recording** .................................................................................................................... 8
  - **Selecting Track Type** .............................................................................................................................. 8
  - **The Metronome** ....................................................................................................................................... 9
- **Punch In and Out** ........................................................................................................................................... 9
- **Audio Pool** ................................................................................................................................................ 10
- **Projects** ...................................................................................................................................................... 12
  - **Load Project** .......................................................................................................................................... 13
  - **Backup & Restore Projects** .................................................................................................................... 13
  - **Creating a New Project** .......................................................................................................................... 14
  - **Saving a Project** .................................................................................................................................... 15
  - **Project Properties** .................................................................................................................................. 16
  - **Transfer your Project to your PC/Mac** .................................................................................................... 17
- **Mixdown** .................................................................................................................................................... 19
  - **Exporting a Mixdown to WAV and CAF Files** ......................................................................................... 19
  - **Mixing Down to 2 Tracks** ....................................................................................................................... 19
- **Transport Panel** ......................................................................................................................................... 20
  - **Quantize** ................................................................................................................................................. 21
  - **Display Mode** ........................................................................................................................................ 22
  - **Time Signature** ....................................................................................................................................... 23
  - **Tempo** ..................................................................................................................................................... 24
  - **Pool** ....................................................................................................................................................... 25
  - **Play Controls** .......................................................................................................................................... 26
  - **Metronome** ............................................................................................................................................. 27
  - **Zoom** ..................................................................................................................................................... 28
  - **FX** ......................................................................................................................................................... 29
  - **Ruler** ...................................................................................................................................................... 30
- **MIDI Recording** ......................................................................................................................................... 31
  - **Quantising Notes** ................................................................................................................................... 31
  - **MIDI Out Channel** ................................................................................................................................. 32
  - **MIDI Record Mode** ............................................................................................................................... 32
  - **Changing Note Velocity** .......................................................................................................................... 32
  - **Modifying Controllers** ........................................................................................................................... 33
  - **Controller Resolution** ............................................................................................................................ 33
  - **MIDI Synchronization** ............................................................................................................................ 33
- **Importing Samples** .................................................................................................................................... 35
- **Pasteboard** ................................................................................................................................................ 36
- **Track View** ................................................................................................................................................ 36
  - **Splitting a Clip** ..................................................................................................................................... 40
  - **Clone Clips** .......................................................................................................................................... 41
  - **Duplicating Clips** .................................................................................................................................. 42
  - **Record Monitor** .................................................................................................................................... 43
  - **Controller Lane** ..................................................................................................................................... 44
    - **Track Type** ........................................................................................................................................ 44
    - **Controllers** ........................................................................................................................................ 44
    - **Controller Resolution** .......................................................................................................................... 45
    - **Track Color** ....................................................................................................................................... 45
    - **Assignable Track Color** ....................................................................................................................... 45
  - **Deleting Controller Data** ....................................................................................................................... 45
Getting Started

Before you jump in and get your hands dirty there are a few things which you need to know in order to get the most out of the software. Meteor is a very demanding product which will attempt to squeeze every bit of processing power it can and then some! You need to understand what is possible and what is not.

In theory if you turn off the effects processing you should be able to record 10-12 mono tracks of audio without too much trouble. The program has been well tested and is quite capable of achieving this so long as other tasks are not running alongside Meteor. If you suffer from audio glitches or dropouts it is almost certainly due to other applications such as Safari or the Mail application hard at work trying to disrupt you. In these cases we suggest you double tap the ‘home’ button to bring up the task manager and shut down as many tasks as you can.

Meteor now supports stereo recording and stereo tracks, but you should use these sparingly, especially if you are using an iPad 1. Stereo tracks require more processing power, and are twice the size of mono tracks. There is little or no benefit of using stereo tracks unless you have a stereo audio interface or are pasting stereo audio from other applications.

If problems persist then try powering off your device by holding the ‘power’ button for 5 seconds then, slide to power off. Wait 10 seconds then power back on again. This reboot procedure will ensure that all memory is returned to the system and Meteor is the only program running.

There are four types of effects available in Meteor, Aux Send, Insert, Record and Master, all of which need to be used in moderation. You can assign effects to your effects rack using the ‘FX’ button in the ‘Transport Panel’. Once effects have been assigned you can change settings via the effect rack which is available on the ‘Effects’ tab at the bottom of the display.

You can allocate up to 3 Aux Send effects, which are common to all tracks and therefore fairly efficient to use. Using the mixer you can redirect part of any track through these global effects using the FX1-3 knobs on the mixer. Aux Send effects are stereo, and their output is returned back into the mix via the FX Return knobs FXR1-3 in the top right of the mixing desk. You should be able to use 3 Aux send effects with around 8-10 tracks of audio, but 12 would be a push.

To relieve some of the strain on the CPU you can use Record effects to add effects to the recorded input so that no additional CPU is required during playback. To hear effects assigned to the record busses you need to enable the ‘Record Monitor’ from the ‘Options’ menu. Remember to turn this off when not in use and ensure you are wearing headphones to avoid feedback.
The Insert effects bus can be used to add up to 3 effects to each track, however you should only do this for the track you are recording and once you’ve finalized a track you should ‘freeze’ it so that the effects are not consuming any CPU. With careful use of the ‘Freeze Insert FX’; option you could have up to 36 Insert effects using absolutely no CPU at all. Just remember when a track is frozen any changes to effect settings will have no effect until the track is ‘unfrozen’ again.

Finally we have Master effects, which are generally used to apply mastering effects such as a graphic equalizer, reverb or compressor. These affect the whole mix and should only be used when mastering or mixing down where CPU usage is not an issue.

By default the audio latency is set to medium, which is around 10ms, but we have integrated delay compensation so as long as you isolate the microphone and speakers you shouldn’t have any problems. If however you hear a delay or feedback you might want to try setting the latency to low which is approximately 5ms.

By default we assume you are using the internal microphone for recording, which is purely a mono signal in the left channel. If you want to record both left and right input channels to a mono audio track then you need to change the ‘Record Input Type’ in the ‘Options’ menu. If you are recording from a stereo sound interface to a stereo track then you should pick ‘Pure Stereo’ from this submenu.

Various options found under the ‘Options’ menu can be used to help lower the CPU usage. If you are suffering from insufficient CPU you may want to try disabling some of these options, in particular the ‘Display Clip Contents’, ‘Display Clip Descriptions’ and ‘Show VU Meters’, all of which will help boost performance.

Also See
- Getting Started
- Your First Recording
- Midi Recording
- Track Types
- Projects
- Transport Panel
- Track View
- Midi Editor
- Editor
- Mixer
- Effects
Terms and Meanings

Before you begin using the program it is advisable to read through the following section in order to familiarize yourself with some of the terms and concepts which will help make the program easier to use.

The following list contains a list of meanings for various terms used throughout this manual.

Terms

Audio Pool: Contains all the clips available for the current project. All your recordings and imported samples appear in the audio pool.

Automation: The ability to perform an action without intervention. In the case of Meteor this is usually associated with controller data used to automate the mixer.

Bus: In Meteor this refers to an audio effects channel usually numbered 1-3.

Clip: A single audio recording. A track may have one or more audio clips.

Controllers: Refers to a set of events which are to be played back as a song is playing to automate such things as volume, pan and effect levels.

Latency: Refers to the delay associated with making recordings. A high latency is good for audio stability but not so good when it comes to recording. Meteor incorporates latency compensation for recordings which should ensure everything stays in sync, but high latencies can be problematic if the input and output are not isolated from each other.

MIDI: Stands for Musical Instrument Digital Interface and is an industry standard protocol that enables electronic musical instruments to communicate and synchronize with each other.

Metronome: An instrument is used to indicate the exact tempo of a composition by playing an audible click on the beat and offbeat.

Mixer: A device that controls the respective volumes of each track, their stereo positioning and effect levels.

Project: A file that contains sequencing information for your sound clips.
**Quantize:** In Meteor the quantize is used as a kind of snap feature which causes clips start times to be snapped to a beat or fraction of a beat. It is also used for making selections in the Track and Editor views.

**Pasteboard:** The Pasteboard is an alternative clipboard used to copy audio data to and from external applications.

**Scrubbing:** Is a term which refers to dragging a cursor over a group of notes in order to listen to them. In the case of Meteor you can use scrubbing in the MIDI editor to hear the notes played on a connected keyboard, drum machine or synthesizer.

**Side Chaining:** Is a form of audio compression that uses another audio source to control the gate of the compressor effect.

**Time Signature:** A time signature is a notational convention used in musical notation to specify how many beats are in each measure and which note value constitutes one beat.

Also See
- Getting Started
- Your First Recording
- Midi Recording
- Track Types
- Projects
- Transport Panel
- Track View
- Midi Editor
- Editor
- Mixer
- Effects
Your Audio First Recording

1) Ensure that the ‘Track’ tab is selected at the bottom of the screen. You should now see all 12 tracks displayed with Track 1 selected.

2) The selected track is designated by a red circle around the ‘Arm’ button under the track number. You can select a different track by tapping the ‘Arm’ button on the required track. The red circle should now appear next to the specified track.

3) Position the play cursor at the beat/bar where you wish recording to begin. To do this simply touch in the ruler area along the top of the screen to move the vertical red play cursor to the desired position.

4) Finally, to begin recording press the ‘REC’ button to arm the recording function then press ‘PLAY’ to begin.

5) To stop recording, press the ‘STOP’ button.

Congratulations, you have made your first recording!

Selecting Track Type

Meteor now supports 3 different track types Audio (Mono), Audio (Stereo) and MIDI tracks.

By default tracks are automatically set to mono audio, but this can be changed from a tracks controller lane. Double tap a tracks ARM button to display the Controller Lane, from here you can select the required track type. For further information see the sections on Track Types and Midi Recording

NOTE: If you are recording from a MONO source it is wasteful of resources to select STEREO tracks. It takes twice the processing power to render a stereo track than a mono, especially if you are using effects. If recording from a stereo source you may need to select ‘Pure Stereo’ as the ‘Record Input Type’ from the ‘Options’ menu.
The Metronome

You may wish to enable the metronome in order to get an audible representation of the selected tempo, especially when recording the first track. Ideally you should lay a drum track first and use that as a guide for recording other tracks.

To enable the metronome press the ‘Metronome’ button in the ‘Transport Panel’ (to the left of the zoom magnifying glass). The metronome dialog will now appear. Select ‘Enable During Recording’ then exit the dialog. If you begin recording again you should hear the beat tapped out by the metronome.

See the section on Metronome for more details.

Punch In and Out

You can use the punch in and out functionality at any time whilst in play mode.

1) Select the ‘Arm’ button on the track you wish to record.

2) During play mode press the ‘REC’ button to begin recording.

3) Press the ‘REC’ button again to return to play mode.

Note: You might want to consider reading the section on optimizing performance as it contains some useful tips on best practices.

Also See

Getting Started
Track Types
Projects
Transport Panel
Track View
Midi Recording
Midi Editor
Editor
Mixer
Effects
Audio Pool

The ‘Audio Pool’ is accessed from the ‘File’ menu and holds all the clips that have been recorded and imported since you started the current project. As mentioned previously clips deleted from the project are still visible in the audio pool. To permanently delete a clip you need to do this from the audio pool dialog.

The audio pool is used to manage the clips used in your project. It allows you to add labels, preview, delete and drag selections into the track and file editors.

Previewing Clips
You can preview a clip at any time by selecting the clip from the list and pressing the ‘Play’ button.

Deleting Clips
To permanently delete a clip, select the clip from the list and press the ‘Delete’ button. You will be asked to confirm your selection after which the clip is deleted. If you delete a clip that is in use in the current project it will also be deleted from the project.

Tidy
Once your composition is complete you may find that you have many clips in your Audio Pool that you didn’t use in your final project. The ‘Tidy’ button permanently deletes all clips from the Audio Pool that are not referenced by the current project, i.e. they are not in use in the Track View.

Labeling a Clip
You can assign a more meaningful description to a clip using the ‘Label’ button. Select a clip from the list and press the ‘Label’ button. The Keyboard will appear allowing you to enter a brief description. To view clip descriptions in Track View you will need to enable ‘Display Clip Descriptions’ from the ‘Options’ menu.
Dragging Clips from the Audio Pool
If you want to drag a clip from the Audio Pool into the Editor or Track views, you need to tap and hold your finger on the graphical representation of the clip until a small floating thumbnail appears. Now drag the clip into the destination window. You can also make a selection and drag the selection into track view if you don't want to paste the complete file.

Copy
The Copy button is an alternative to dragging a clip into Track or Editor views. You can copy a whole clip or a selection into the clipboard and use the ‘Edit->Paste’ option to paste a clip into Track View.

Scrolling and Zooming
When viewing the graphical representation of an audio clip you can zoom in and out using the pinch to zoom technique (2 finger pinch). Once zoomed you can scroll left to right as you would expect.

The PasteBoard
The PasteBoard options allow you to perform copy and pasting of sample data from one application to another. Both stereo and mono samples can be pasted into the audio pool. If a stereo sample is pasted you will be prompted whether to create a single mono clip or split it into two clips representing the left and right channel. You can also copy samples, or a selected range of a sample to the global PasteBoard.

Importing Songs and Samples
The musical symbol on the toolbar displays an import menu allowing you to import audio from a file or from your iPod library. If the imported file is stereo you will be asked if you wish to split the file into two mono tracks.

Please Note: There is a physical limit of 999 clips per project. This should be more than enough to meet your needs for a single project.

Also See
Getting Started
Your First Recording
Track Types
Projects
Transport Panel
Track View
Midi Recording
Midi Editor
Editor
Mixer
Effects
Projects

A project is used to save a composition and all its associated recordings. Each project has an Audio Pool which contains the projects recordings. You can create a new project by selecting the ‘New Project’ option from the ‘File’ menu whilst in Track View.

Also See
Getting Started
Your First Recording
Creating a New Project
Load Project
Saving a Project
Project Properties
Transfer your Project to your PC/Mac
Mixdown
**Load Project**

The ‘Load Project’ option can be found in the ‘File’ menu. When this option is selected it will open the Project Explorer. Each project is displayed as a snapshot of your last saved position and includes the author, description, date and combined file size of all files in that project.

![Project Explorer](image)

To load a project select the file you require and press the ‘Load’ button.

**Backup & Restore Projects**

You can create a backup of your project from the Project Explorer window by selecting a project and pressing the ‘Backup’ button. This creates a single compressed backup file which contains both the project and the contents of the audio pool. You can retrieve this file using an FTP client and browsing to the ‘Backups’ folder once connected.

To restore a backup simply select the backup you wish to restore and press the ‘Restore’ button. The file will now be restored. Please be aware that the project will be restored to its original project name so if a project of that name exists it will be overwritten / merged. You can avoid this by either deleting or renaming your old project. If you attempt to restore a backup of a project currently open in the Meteor, then you will be prompted whether you wish to overwrite or not. If you choose to overwrite then the currently restored project is automatically loaded.

Also See:
- Load Project
- Saving a Project
- Project Properties
- Transfer your Project to your PC/Mac
**Creating a New Project**

To start a new project simply Select the ‘New Project’ option from the ‘File Menu’. Enter your projects name and press return. You should now see an empty Track Editor screen ready for you to start constructing your song.

Once a new project is created you should select ‘Project Properties’ from the ‘File’ menu and enter an ‘Author’, ‘Title’ and ‘Description’. This information comes in handy when browsing through compositions in the ‘Project Browser’

Also See:
- Load Project
- Saving a Project
- Project Properties
- Transfer your Project to your PC/Mac
- Mixdown
**Saving a Project**

There are two options for saving a project:

**Save Project** - This saves the currently loaded project using the existing project name without prompting for a new name.

**Save Project As** - This option allows you to save the currently loaded project with a new name. This will effectively create a backup of your project making a copy of all clips in your existing audio pool.

Also See:
- Load Project
- Saving a Project
- Project Properties
- Transfer your Project to your PC/Mac
- Mixdown
**Project Properties**

Selecting ‘Project Properties’ from the ‘File’ menu displays a dialog allowing you to add some descriptive information to your project file such as author, title and description. This will assist you in selecting projects from your Project Explorer.

Also See:
- Load Project
- Saving a Project
- Project Properties
- Transfer your Project to your PC/Mac
Transfer your Project to your PC/Mac

In order for you to transfer your projects, backups or exported files to a desktop computer we have provided you with a quick and easy to use FTP solution.

To FTP your project you need to select ‘Enable FTP’ in the ‘Options’ menu and select ‘On’. You will now see a dialog appear with information you will require to retrieve your files either using your Internet Browser or an FTP client.

The dialog will display something along the lines of:
ftp://192.168.1.2:20000 (IP Address and Port Number).

An IP address is a unique number given to each computer connected to your router. This number can change from time to time depending on the number of computers connected. It consists of a set of 4 numbers separated by commas, and generally starts 192.168.xxx.xxx (the xxx being determined by your own network). To identify traffic belonging to different programs we use ports. In other words your web browser uses a different port to your email client, but both pieces of software are running on the one computer and so share the same IP Address. In our case Meteor uses port 20000 which is always a fixed number.

ftp://xxx.xxx.xxx.xxx:20000

If you type the above line (replacing the xxx.xxx.xxx.xxx part with your IP address) into the address bar of a web browser such as Internet Explorer or Safari you should see a list of files and folders which you can navigate. Simply drag and drop files onto your desktop to copy them to your Mac or PC. If you are prompted for a user name and password simply choose to connect as a ‘guest’ and leave the user name and password blank

Note: Using a web browser only allows you to copy files off your iPad, not copy files too the iPad.
Alternatively you could use an FTP client such as FileZilla which is a free download for both PC and Mac. You need to create an anonymous/guest login without a user name and password, just set the host address as your IP address and change the port to 20000 and that’s it. FileZilla has a quick connect toolbar which simplifies this operation.

The benefit with using an FTP package is that you can copy files too your iPad as well as copying to your desktop computer

Please Note: FTP transfer is more reliable if you set your FTP packages ‘Maximum Simultaneous Transfers’ to 1. This option can be found in FileZilla Settings dialog under ‘Transfers’.

Also See:
- Load Project
- Saving a Project
- Project Properties
- Transfer your Project to your PC/Mac
Mixdown

The Mixdown feature can be used to mix your entire song down to a single exported file, or to mix all tracks down to two mono tracks, one for the left and another for the right channels.

Exporting a Mixdown to WAV and CAF Files.

To export a finished mix of your song to an uncompressed WAV or compressed CAF file you need to select ‘Mixdown’ from the ‘File’ menu, then one of the ‘Mixdown to File’ options from the submenu. At this point you will be prompted for a file name to be used to save your exported file. The file will be saved in the 'Exported' folder of your iPad. You can retrieve exported file(s) for use on a desktop computer using the built in FTP client. See the section on Transferring your Project to your PC/Mac for more information on using FTP (file transfer protocol).

Mixing Down to 2 Tracks.

You may reach a point where all 12 tracks are used by imported / recorded clips and there is very little room to add new clips to the stage. One solution would be to mix all of your tracks down to two tracks which would represent the left and right channels of your song. This allows you to delete the original clips and free up ten tracks to begin again. This process is often referred to as 'bouncing' tracks.

To accomplish this you need to select the ‘Mixdown’ option from the ‘File’ menu, then 'Mixdown to 2 Tracks'. This will display a 'Mix Down' dialog allowing you to specify various options. You need to specify the destination for the left and right channel audio clips created during the mixdown, the default being tracks 11 and 12. If you are using any effects such as echo or reverb that fade away after the song ends you might wish to extend the padding which is essentially blank space appended to the end of your song.

You may also wish to select the option to remove all existing clips on all tracks if you don't mind loosing those. The original recordings will not be deleted from your audio pool.

Also See:
Load Project
Saving a Project
Project Properties
Transfer your Project to your PC/Mac
Transport Panel

The 'Transport Panel' is located at the top of each of the 4 program areas and allows you to quickly change many global settings such as the quantize (snap), display mode, time signature, tempo etc. You can also access the various playback and record options as well as the Audio Pool, Undo, Record Monitor, Metronome and FX Assignment windows.

Also included are the ‘Record Monitor’ ‘Overview’ and ‘Midi Record Mode’.

Also See:
- Display Mode
- Quantize
- Time Signature
- Tempo
- Pool
- Play Controls
- Metronome
- Zoom
- FX Assignment
- Track Overview
- Midi Record Mode
- Midi Editor
- Ruler
- Record Monitor
**Quantize**

Quantize is the facility that enables you to choose the interval that you wish to snap the start positions of samples. For example if you select a sample to move and Quantize is set to one bar, the sample will move in one bar increments along the track. Quantize can be selected from one bar down to 1/32 of a beat for more exact positioning of a sample or can be switched off for manual placement.

NOTE: The ‘Quantize’ is also used for making selections, editing clips and whilst using the ‘Trim’ function.

Also See:
- Display Mode
- Quantize
- Time Signature
- Tempo
- Pool
- Play Controls
- Metronome
- Zoom
- FX Assignment
- Track Overview
- Midi Record Mode
- Midi Editor
- Ruler
- Record Monitor
**Display Mode**

Display Mode controls the units of measurement on the Ruler.

There are two options on the Ruler:

**Beats and Bars:** This changed the units of measurements to Beats and Bars as described by the currently selected time signature.

**Time:** In this mode the Ruler displays Hours, Minutes and Seconds. Switching to this mode enables you to see how long your composition is in real terms. ‘Time Signature’ and ‘Tempo’ are not available when Time mode is selected.

Also See:
- Display Mode
- Quantize
- Time Signature
- Tempo
- Pool
- Play Controls
- Metronome
- Zoom
- Track Overview
- Midi Record Mode
- Midi Editor
- Ruler
- Record Monitor
**Time Signature**

Time Signature tells you how the beats in your composition are to be counted in terms of its rhythm. Time signatures consist of two numbers written like a fraction.

The top number of the time signature tells you how many beats to count. This could be any number. Most often the number of beats will fall between 2 and 12. The bottom number tells you what kind of note to count. That is, whether to count the beats as quarter notes, eighth notes, or sixteenth notes. So the only numbers you will see as the bottom number (the denominator) will correspond to note values:

1 = whole note (you’ll never see this)
2 = half note
4 = quarter note
8 = eighth note
16 = sixteenth note

Also See:
Display Mode
Quantize
Time Signature
Tempo
Pool
Play Controls
Metronome
Zoom
Track Overview
Midi Record Mode
Midi Editor
Ruler
Record Monitor
**Tempo**

Tempo is the term for the speed of a piece of music and is usually displayed in BPM (Beats Per Minute). The greater the tempo the faster the pace of the music.

The tempo can be adjusted whether using the Quick Tempo menu on the ‘Transport Panel’ or from the ‘Metronome Setup’ window. The Quick Tempo menu allows you to choose a tempo in 10bpm increments and covers the most popular settings. If you need to be more precise and specify exact an tempo you need to do so in the ‘Metronome Setup’ window.

Also See:
- Display Mode
- Quantize
- Time Signature
- Tempo
- Pool
- Play Controls
- Metronome
- Zoom
- Track Overview
- Midi Record Mode
- Midi Editor
- Ruler
- Record Monitor
**Pool**

The Audio Pool contains all the imported / recorded samples since you started the current project. Clips deleted from the Track View are still visible in the audio pool. To permanently delete a clip you need to delete the clip from the audio pool dialog.

Click here for more information on using the Audio Pool window.

Also See:
- Display Mode
- Quantize
- Time Signature
- Tempo
- Pool
- Play Controls
- Metronome
- Zoom
- Track Overview
- Midi Record Mode
- Midi Editor
- Ruler
- Record Monitor
Play Controls

These are standard controls as you would expect to see on a music player apart from perhaps the Loop button. This enables you to listen to a looped selection of your composition. A looped region can be made by dragging a selection in the ‘Ruler’.

Also See:
Display Mode
Quantize
Time Signature
Tempo
Pool
Play Controls
Metronome
Zoom
Track Overview
Midi Record Mode
Midi Editor
Ruler
Record Monitor
**Metronome**

The metronome is used as a guide to indicate the tempo of your composition during the recording process. If you are recording a musical composition then you will almost certainly need to use the metronome as a guide when laying down your first track.

The metronome setup dialog is available from the ‘Metronome’ button on the ‘Transport Panel’ at the top of the display.

The Metronome gives you more in depth control of the Tempo by allowing you to specify exact BPM values rather than those specified in the Quick Tempo menu. It also enables you to select if the metronome is audible during Playing and Recording tracks. When enabled during recording, you will only hear the metronome as the track is recording it is not physically recorded to the track.

You can also use the Tap Tempo button to get a close estimation of the BPM of a piece of music. Press the Tap button repeatedly with each beat of the music the tempo will by automatically set for you.

The Metronome also includes a ‘Count In’ facility which can be set to 1 or 2 bars. To use the ‘Count In’ facility, select the required number of bars, then position the cursor where you wish to start playing / recording. When you press play, the metronome will sound for a specified number of bars before the play / record functionality is engaged.

Also See:
- Display Mode
- Quantize
- Time Signature
- Tempo
- Pool
- Play Controls
- Metronome
- Zoom
The ‘Zoom’ dialog allows you to change the magnification level of the wave form on display; more accurate selections can be made using the zoom functionality. In Track View you can zoom in up to 100% allowing a 1:1 representation of individual samples. Edit mode zooming is restricted dependant on the size of the wave you are editing.

Also See:
- Display Mode
- Quantize
- Time Signature
- Tempo
- Pool
- Play Controls
- Metronome
- Zoom
- Track Overview
- Midi Record Mode
- Midi Editor
- Ruler
- Record Monitor
The FX button allows you to assign audio effects to one of 4 effect buses. Once effects are assigned they can be configured from the ‘Effects Rack’ tab on the navigation bar.

For more information about using effects in Meteor see the section on the Effects Rack View.

Stereo Effects cannot be assigned to Stereo Tracks.

Note: After Assigning Effects ensure the respective effect bus is enabled in the mixer. By default ‘Insert’ effects are enabled in the mixer, but ‘Aux Send’ effects are not, because they are applicable to all tracks.

Also See:
Display Mode
Quantize
Time Signature
Tempo
Pool
Play Controls
Metronome
Zoom
Track Overview
Midi Record Mode
Midi Editor
Ruler
Record Monitor
Effects Rack View
**Ruler**

The ruler bar gives you a physical reference as to the position within a composition. You can change the position of the play cursor by simply touching a point on the ruler.

The Ruler can also be used to select regions which can be looped. Place your finger on the ruler where you want the loop to start and drag along the ruler to where you want the loop to end. If you press the ‘Loop’ and ‘Play’ buttons in the Transport panel your loop will start to play enabling you to audition a section of your song.

Also See:
- Display Mode
- Quantize
- Time Signature
- Tempo
- Pool
- Play Controls
- Metronome
- Zoom
- Track Overview
- Midi Record Mode
- Midi Editor
- Ruler
- Record Monitor
MIDI Recording

In order to record midi data you first need to designate a track as a MIDI track. You can do this by double tapping a tracks ARM button in Track View. This will open the controller lane which will reveal a ‘Track Type’ combo. Tap this combo to display a list of track types and select ‘MIDI’ from the list. At this point any existing data on the selected track will be wiped.

If you have a MIDI keyboard connected to your iPad you should notice the peak meter to the left of the track light when you hit a note on the keyboard. If not then MIDI may be disabled within Meteor. Check the ‘MIDI Setup’ dialog on the ‘Options’ menu to ensure MIDI is enabled.

Once you have verified that your keyboard is connected and Meteor is receiving MIDI data you are ready to begin recording.

Press the Metronome button on the ‘Transport Panel’ to display the Metronome dialog. Set the Tempo, enable the ‘Metronome During Record’ and ‘Count In’ if required before exiting the dialog.

Position the cursor by tapping in the Ruler at the location you wish to begin recording and press the ‘REC’ button to prepare for recording. Now simply press the ‘PLAY’ button and wait for the count in to begin. Recording will begin once the count in is complete and you should see any notes you play appear on screen in a newly created MIDI clip. Press ‘STOP’ at any time to stop recording.

NOTE: All notes played during a recording session are stored in a single MIDI clip. MIDI clips are given a unique ID which starts with the letter 'M' to denote a MIDI track, followed by a number. This number is used by Meteor to distinguish one clip from another. If no notes are entered during a recording session then the clip is automatically deleted once ‘STOP’ is pressed.

Quantising Notes

It is highly unlikely that every note you play is exactly on the beat, so you may wish to correct this using the quantise feature on the ‘Edit’ menu. This option quantises all the notes in the selected clips, as well as the clip position within the Track View window. You need to specify the fractional beat position to which all notes must fall, and notes are adjusted accordingly. You can always use the ‘Undo’ to remove any changes made by the Quantise and try another value if you wish.
**MIDI Out Channel**

By default each newly created MIDI channel's ‘Out’ channel is set to ‘Any’. This tells Meteor to send all recorded notes back to the same channel they originated. This is very useful when accepting MIDI data from multiple channels, either from an external sequencer or your DAW, but you may want to force the output to a specific output channel for playback. You can do this by specifying a MIDI out channel from a tracks controller lane.

Another reason you may wish to set a MIDI out channel is if you are wanting to use Meteor's mixer to control volume and pan settings for each channel on your keyboard. If MIDI track 1 has it’s ‘Out’ channel set to ‘Any’ then it will send volume and pan data to channel 1. If channel 2 is set to ‘Any’ then it will output volume and pan data to channel 2 and so on. If you explicitly specify a MIDI Out channel then all volume and pan information will also be sent to that channel.

**MIDI Record Mode**

By default the MIDI Record Mode is set to ‘Merge’, but you can change the mode using the combo button at the top right of the ‘Transport Panel’.

- **Merge Mode** allows you to merge overlapping clips once you stop recording. This is great for building up a drum sequence where you may want to record the bass drum and snare on one recording pass, and the hi-hats on another pass. The result is a single clip containing the whole drum pattern.

- **Overwrite Mode** allows you to replace a section of a clip with newly recorded data. You still end up with a single clip, but any existing data is erased.

- **Normal Mode** is a handy way of recording a session and keeping all the recorded data separate from other MIDI data on a track. The result is a new clip and no merging or overwriting will take place.

**Changing Note Velocity**

You can change the note velocity of a note or group of notes quickly and easily by using the ‘Controllers’ lane. Ensure that ‘Note Velocity’ is selected in the ‘Controller’ combo, select the ‘Pen Tool’, tap and hold in the controller area then drag your finger over the notes. If you have a group of notes that have similar start times it might prove difficult to edit the volumes of individual notes. For that you might want to consider purchasing the MIDI Editor plugin which gives you full control over editing MIDI clips.
Modifying Controllers

You can modify controllers such as pitch bend and modulation wheel etc. using the ‘Controller’ lane. This works in exactly the same manner as editing note velocities described above.

To begin you need to select a CC to edit using the ‘Controllers’ combo box to the left of the controller lane. The ‘Controllers’ combo displays all the frequently used controllers and may not contain a specific controller you want to use. To add a controller to the list press the ‘Add’ button. A menu of all the 128 available MIDI controllers will appear. Select the controller you wish to edit from this list and it will be added to the frequently used controllers list.

Controllers are added to the actual MIDI clip itself, so you can only paint controller data into a ‘Selected’ clip, and not outside its boundaries. To select a clip simply tap on it and ensure it has a RED selection before continuing.

You can now use the controller tools to the left of the controller lane to add and remove controller data to the selected clip.

Controller Resolution

Depending on the controller you are editing, you may need to paint a finer resolution for real-time manipulation of things such as Pitch Bend. You can do this by pressing the ‘Controller Resolution Button’ to the left of the controller lane. Keep in mind that adding too many controllers is not a good thing so use them sparingly, and use the course resolution where possible to prevent over saturation.

MIDI Synchronization

Meteor has the ability to send MIDI clock to an external sequencer or drum machine in order for them to stay in sync with Meteors tempo. To use this feature you need to enable the MIDI clock option in the ‘MIDI Setup’ dialog which can be found on the ‘Options’ menu.

![MIDI Setup](image)

When MIDI clock is enabled it will transmit a set number of pulses each quarter note to ensure perfect synchronization with your sequencer. Meteor also transmits MIDI Start and Stop messages when this option is enabled.
You will also notice an option to ‘Send Song Position’ which ensures your sequencer starts in the correct place. If you start playing a song at bar 4, then Meteor will send this position before it sends a MIDI Start message to begin playback.
Importing Samples

Every project you create in Meteor has its own Audio Pool. All newly recorded and imported clips are stored here. You can import samples into your Audio Pool whether from your existing ‘iPod Library’ or from samples uploaded to Meteor via FTP.

Importing Songs from your iPod Library

To import a song into your Audio Pool you first need to click on the ‘Editor’ tab to load the file editor view. You should now be able to select the ‘Import From iPod Library’ option from the ‘File’ menu. Simply select a file to import or press the ‘Cancel’ button.

Importing Sound Samples

Meteor allows you to import various types of sample data which you might have copied to your device as well as being able to load clips from other projects.

To import a sample select ‘Import From File’ from the ‘File’ menu. A dialog will appear allowing you to browse the contents of Meteors file area and preview any audio files you might find. Simply tap on the sample to import into Meteor. The newly imported sample will appear in the editor and will be assigned a clip id for reference.

By default the dialog appears showing the contents of the ‘Samples’ folder. If you are uploading samples to your device it is recommended that you upload them you the Samples folder separating sample types into subfolders such as ‘bass’, ‘drum’, ‘layer’, ‘effect’ etc.

Imported clips are automatically assigned a description which is either the track and artist or the file name if you are importing from file. You can modify the description using the ‘Label’ option in the ‘Audio Pool’ dialog on the ‘Transport Panel’.

Also See

Audio Pool
Fade In/Out
Clear
Gain
Normalize
DC Offset
Apply Effect
Time Stretch
Pitch Shift
Mixer
Effects Rack
**Pasteboard**

The ‘Pasteboard’ can be used to copy audio between audio applications so long as they support the standard. You can copy your whole song, sections of your song or individual samples. It is an alternative to cut, copy and paste which only work locally within Meteor.

**Copying a Song From Meteor**

You can copy an entire composition to the pasteboard from the ‘Track View’ tab. Simply select the ‘Pasteboard -> Copy Song to Pasteboard’ option from the ‘Edit’ menu.

Alternatively you can copy a part of a song by first dragging a loop in the ruler. Simply press, hold and drag within the ruler to create a loop. The looped region will turn dark blue. Now select ‘Pasteboard -> Copy Selected Loop To Clipboard’ from the ‘Edit’ menu.

**Copying a Recorded Clip From Meteor**

You can copy part of a recorded clip to the pasteboard from the ‘Editor View’ tab. To do this you need to load a sample into the editor. Press the ‘Pool’ button to bring up the Audio Pool, select the sample you wish to load then press, hold and drag the thumbnail into the editor window.

Now you need to make a selection (not a loop) by dragging a selection on the audio data itself. Use the zoom and snap features to select the precise amount of data to copy. Finally select ‘Pasteboard -> Copy’ option from the ‘Edit’ menu.

**Pasting Audio Into Meteor from the Pasteboard**

You can paste audio into the ‘Editor View’ tab of Meteor to create new clips or to insert into existing clips.

Simply select ‘Pasteboard -> Paste As New’ from the ‘Edit’ menu to create a new clip in Meteor using the contents of the Pasteboard.

Selecting ‘Pasteboard -> Paste Into’ to paste the contents of the pasteboard into the currently loaded clip at the cursor position.

**Advanced Pasteboard**

4Pockets have added an extension to the standard pasteboard which will allow copying of whole songs between 4Pockets applications. This will for instance allow you to copy a composition created in Aurora to Meteor with full separation of individual tracks. This method also allows for copying of mix data such as tempo, volume and pan settings per track.
These options can be found within Track View under the ‘Edit’ menu, in a submenu called ‘Multi-Track PasteBoard’. At this moment in time the feature is not implemented in Aurora, but will be in future versions.

The ‘Copy Song to PasteBoard’ copies each fully rendered track (including insert effects and automation) to the clipboard. If you use this option then paste into other packages that do not support ‘Multi-Track Pasteboard’, you will most likely end up with all tracks appended end on end. A work around is to use the standard ‘PasteBoard’ and use the mute feature to make multiple copy and pastes.

You can use ‘Paste Song From PasteBoard’ to paste a complete song from the PasteBoard into a new project. This could be used as a method of creating a mixdown which renders all effects and automation, freeing up CPU and allowing for glitch free playing if your project is getting too CPU hungry. To do this select ‘Multi-Track PasteBoard -> Copy Song To PasteBoard’, create a new project, then select ‘Multi-Track PasteBoard -> Paste Song From PasteBoard’. You now have a project free of effects but with all tracks and mix intact.

Also See:
- Aux Send Effects
- Insert Effects
- Record Effects
- Master Effects
- Delay
- Reverb
- Compressor
- Chorus/Flanger
- Graphic Equalizer
- Distortion
- Tone Boost
- Side Chaining
Track View

The Track View editor screen is used to build your composition by positioning audio clips on the 12 available tracks.

When you record an audio clip it is automatically placed on the armed track. You can also drag previously recorded and imported clips from the Audio Pool into the Track View. Clips can easily be dragged around the stage and manipulated with the many editing options available.

Mute & Solo
You may occasionally want to mute a certain track whilst listening to your composition. You can do this by pressing the ‘Mute’ button which is a blue button located on the left of the track. When the ‘Mute’ button is lit, the track is muted. There may also be times when you wish to listen to one or more tracks in isolation. To do this press the green ‘Solo’ button next to the desired track. Solo takes priority over mute which basically means if you have solo button selected for any track, it will be heard regardless of its mute status. To return to normal playback you need to turn off all the solo and mute buttons.

Inserting a Clip
To insert a clip into the Track View editor select ‘Pool’ from the Transport Panel. This will display the Audio Pool dialog containing a list of all the audio clips available to your project. When you select a clip from the list it will appear in the preview window at the top of the Audio Pool dialog. To copy this clip, tap and hold on the preview image and a small thumbnail will appear. Simply drag that to the required position and track on the Track View editor.

You can also make a selection within the preview window prior to dragging to the Track View editor. This allows you to copy a portion of a clip rather than the whole thing.
**Positioning a Clip**
You can move one or more clips by first tapping on the clip to toggle its selected status. A red highlight box appears around the clip once it is selected. Now tap on a selected clip, hold for half a second then simply drag the clip(s) to the new location. The pause is required to differentiate between scrolling the view and dragging items. Please note that if you tap and hold for too long a selection menu will appear. You can also select multiple clips by dragging a selection over the clips you wish to select.

**Removing a Clip**
To remove clips from the stage, simply tap one or more clips to select them (a red selection border will appear on each selected clip), then select ‘Cut’ from the ‘Edit’ menu. This doesn’t physically delete the clip as they will still remain in your projects Audio Pool. To permanently delete clips you need to delete them from the Audio Pool dialog.

**Copy and Paste a Clip**
Select the clip(s) you wish to copy, select ‘Copy’ from the ‘Edit’ menu. This will copy the selected clips to the clipboard. Now position the play cursor at the location you wish to paste and select ‘Paste’ from the ‘Edit’ menu. You can reposition the clips after the paste by simply dragging to a new position / track.

**Snap / Quantize**
When dragging clips you will notice that they snap into position you can snap to a BAR, a BEAT or a fraction of a BEAT. You can change this snap value using the Quantize control on the Transport Panel.

**Display Clip Descriptions**
Displaying clip descriptions may be helpful when you are working on a large project so you can see at a glance what clips you have on each track. You can turn descriptions ‘On’ and ‘Off” by selecting ‘Display Clip Descriptions’ from the ‘Options’ menu. You can add a description to a clip from the Audio Pool using the ‘Label’ option.

*Note: Imported samples are automatically labeled for you using the imported file name.*

**Display Clip Contents**
When enabled this option renders the waveform data for each clip on the stage. This waveform may help you identify clips but since you could potentially have many megabytes of samples on stage at any one time, rendering clips is very CPU intensive.

If your project uses lots of effects and lots of tracks and experience audio stutters and glitches, you may want to consider turning this off. You can disable this option from the ‘Options’ menu.
Splitting a Clip

Once you have recorded a clip you may want to tidy things up by deleting part of the recording or chopping the recording into multiple pieces.

To do this you need to select a clip then position the play cursor at the exact position you wish the split to occur. Tap and hold on the clip until a popup ‘Options’ menu appears. Select the ‘Split Audio/Midi Event’ at the ‘Cursor’ option from the menu to perform the split.

Notice after the split that both pieces have the same sample identifier / number. This is because both of these clips reference the original recording. If the whole purpose of the split was to throw away part of a recording and reclaim the memory, you should duplicate the clip you want to keep so that it is assigned a new clip identifier, then you are free to delete the original.

To undo a Split select the ‘Edit’ menu and ‘Undo’ Split At Cursor.

Also See
- Getting Started
- Projects
- Transport Panel
- Tracks
- Editor
- Midi Editor
- Mixer
Clone Clips

There are many instances where you may wish to have the same clips appear more than once in your composition. If for instance you are recording a musical score, you may have two or three chorus parts to your song, all containing the same clips. Of course you could record the chorus again, but this is wasteful of both your time and memory. By cloning a clip, it simply places a second reference to the same recording onto the stage. To clone one or more clips, ensure the clips are selected and highlighted in red, then tap and hold on a selected clip until the popup ‘Options’ menu appears. Select ‘Clone Selected’ from the menu.

You then drag the highlighted Cloned track into the required position.

Please be aware that cloned tracks reference the same original recording, so making changes or applying effects to the original recording will affect all of its clones. To avoid this you may want to use the ‘Duplicate Selected’ option to create unique clip before applying any effects.

Also See
- Getting Started
- Projects
- Transport Panel
- Tracks
- Editor
- Midi Editor
- Mixer
- Effects
**Duplicating Clips**

This comes in very handy when you want to create a duplicate clip which is no longer associated with the original. Suppose you make a recording, and use the ‘Split Clip At Cursor’ option to trim off some unwanted audio from the beginning and end of your recording. You will now have 3 clips all referencing the original recording (the clip identifier in the top left of a clip signifies this). If you were to simply delete the recording from the Audio Pool, all associated clips referencing the recording would be deleted from the stage.

To avoid this problem you would duplicate those clips you wish to keep then delete the original recording.

To duplicate a clip, tap the clip to highlight it, then tap and hold on it until the ‘Options’ popup menu appears, select ‘Duplicate Selected’ then choose ‘Replace’ and a duplicate clip will be created in your Audio Pool, replacing the original clip on the stage.

Remember that duplicating clips creates a completely new sample in your Audio Pool, rather than creating a reference to the original recording. You should only use this function if you either intend to delete the original clip or want to edit a clip without effecting the original.

After duplicating a clip its numerical clip identifier will change to reflect that it is referencing a new recording in the audio pool. Simply cloning a clip does not change the clip identifier because it still points to the original recording.

Also See
- Getting Started
- Projects
- Transport Panel
- Track View
- Effects
- Editor
- Midi Editor
- Mixer
Record Monitor

When making recordings you might want to listen to what is about to be recorded along with previously recorded tracks. This is especially useful if you are using Record Effects and want to preview their settings. To enable this option select ‘Record Monitor’ from the ‘Options’ menu and select ‘On’ from the submenu. You should ensure that you are wearing headphones before enabling the Record Monitor to avoid unwanted feedback.

Once you have finished recording you should turn off the record monitor to save CPU. Also ensure you disable the option before unplugging your headphones.

The record monitor option is also available as a toggle button in the Transport Panel window.

Also See
Getting Started
Projects
Transport Panel
Track View
Effects
Editor
Midi Editor
Mixer
Controller Lane

The controller lane allows you to specify whether a track is to contain audio or midi data as well as add automation to a track such as volume, pan and effect level changes.

To view the controller lane tap on the ‘Arm’ button to activate and tap again to expand the track. Once a track is expanded you will see a number of additional buttons which will be explained below.

Track Type

Specifies whether the track contains AUDIO or MIDI data. You can change the track type at any time but any data on the track will be lost. If the track type is set to MIDI then the ‘Out’ box can be used to specify a midi channel to which any recorded data will be sent. By default this is set to ‘Any’ which means that all data is sent back to the same midi channel it originated.

Controllers

As you’ve probably discovered, the mixer gives you control over the volume and stereo positioning of each audio track, but what if you want to change settings part way through your composition. You may for instance want to pan a track from left to right or fade in a track over several bars. This and much more can be accomplished using controllers.

When a track is set to MIDI then the controllers menu will display a list of most common controllers, as well as those that are currently used in your composition. An asterisk will appear next to any controller to denote that there are events of that type on a track. If you want to add an extra controller to the list press the ‘Add’ button and select one of the pre-defined midi controllers.

At the top of the controller lane are 4 small buttons, the pen tool, the eraser and the straight line tool.
Selecting the pen tool allows you to draw data into the controller lane. You can choose the type of controller (i.e. volume, pan, send fx level etc.) from the controllers list box.

Be careful not to go overboard with controllers, they bloat the size of your project so please use sparingly. If all you require is an odd automated volume change here and there, just place single entries in the controller lane rather than point the entire track.

The eraser tool can be used to remove controllers from the controller lane and you can use the line tool to quickly draw smooth ramps for fading in and out.

Please note that differentiate scrolling from drawing into the controller lane you need to tap on the screen and pause slightly before controller data can be input.

**Controller Resolution**

Depending on the controller you are editing, you may need to paint a finer resolution for real-time manipulation of things such as Pitch Bend. You can do this by pressing the ‘Controller Resolution Button’ to the left of the controller lane. Keep in mind that adding too many controllers is not a good thing so use them sparingly, and use the course resolution where possible to prevent over saturation.

**Track Color**

The ‘Color’ button displays a popup menu allowing you to assign a select color to each track. The colors are used to render clips associated with a track and to easily identify a track in the mixer.

**Assignable Track Color**

You may wish to assign specific colours to specific parts of a song to make it easy to identify, i.e you may wish to make chorus elements blue. This can be done by selecting a clip, then go to the ‘Edit Menu’, select ‘Assign Clip Colour’ and “Set Clip Colour” you can then select the clip colour. To revert the clip color back select ‘Set as Default’.

**Deleting Controller Data**

If you want to quickly delete ‘Controller Events’ from a track you can do so from the ‘Del’ button ot from the ‘Controllers’ popup menu. Simply tap and hold for a second in the controller lane to display the menu.
You can choose to delete controller events for the currently selected event type (i.e. volume, pan etc.) or events for all controller types.

You will also notice cut, copy and paste options in the controller menu. These options allow you to copy controller events from one location to another or from one track to another. To select controllers drag a selection over the track itself, not over the controller lane. If the controller lane is open, controller events will be selected.

**Freeze FX**

The Freeze FX button can be used in conjunction with Insert effects to reduce the CPU load. See the section on Freeze FX for more information on using this feature.

Also See
- Getting Started
- Projects
- Transport Panel
- Track View
- Effects
- Editor
- Midi Editor
- Mixer
**Freeze Insert Effects**

You can add up to 3 Insert effects to each of Meteors 12 tracks, but doing so would very quickly bring the iPad’s CPU to its knees. You should always try to use effects sparingly, using global Aux Send effects of Record busses where you can.

To help relieve the burden on the CPU you should make use of the ability to ‘Freeze’ effects. This is specific to Insert effects and cannot be applied to any other type of effect.

You can ‘Freeze’ insert effects by using the ‘Freeze Insert FX’ button in the ‘Controller Lane’ of the Track View window, or from the Insert FX button in the Mixer View window.

**Track View**
To view the controller lane tap on the ‘Arm’ button to activate and tap again to expand the track. Once a track is expanded you should see the ‘Freeze Insert FX’ button.

Pressing this button renders the track with all its Insert effects applied so that it relieves the CPU of rendering effects in real time. While a track is frozen it is temporarily unavailable for edit and the word ‘Locked’ appears on the track itself. Changing the Insert effects parameters has no effect until the track is unfrozen.

**Mixer View**
You can perform the same operation from the Mixer view by pressing the Insert FX button on the appropriate track lane of the mixer. The ‘Insert FX’ button is a small square blue button which illuminates when Insert effects are enabled. Pressing this button displays a menu containing several options including ‘Freeze Track’.

You can unfreeze the track at anytime by pressing the ‘Freeze Insert FX’ button again.

Also See
- Getting Started
- Projects
- Transport Panel
- Track View
- Effects
- Editor
- Midi Editor
- Mixer
Editor View

Once you have recorded a clip you can load the clip into the sample editor for further trimming and processing. You can do this in one of two ways, either by selecting a clip in Track View and selecting ‘Edit’ from the clips popup menu, or by dragging a clip from the Audio Pool directly into the Editor window.

Please Note: You drag the thumbnail of the clip and not the file name from the listbox. Tap, hold (until a thumbnail appears) then drag the image to the editor window.

The Editor window also allows you to import external samples and files from your iTunes library directly into the projects audio pool. Use the ‘Import From File’ and ‘Import From iPod Library’ functions available from the ‘File’ menu to achieve this.

NOTE: You can only edit samples that are part of your project.
Once you have loaded a sample you can begin editing. As a general rule, most effect processing is carried out using a selection so only the selected part of a sample will be affected. You can always use the undo feature if you make a mistake.

You can scroll around the editor by dragging from left to right. If you touch, hold (for a second) then drag you can make selections. The ‘Cut’, ‘Copy’ and ‘Paste’ operations work as expected allowing you to remove or move sections of a recording.

There are many other editing options available to you which are all explained via the links below.

Also See
 Fade In/Out
 Clear
 Gain
 Normalize
 DC Offset
 Apply Effect
 Track View
 Effects
 Editor
 Midi Editor
 Mixer
**Fade In/Out**

The Fade In and Out buttons within the Editor View allow you to perform volume fades over time. Fade operations only effect the current selection and so this is used to determine the length of the fade.

**Fade In**
This enables you to apply a volume fade in, increasing the volume from left to right.

**Fade Out**
As you would expect this works in the same manner as the Fade In option but in reverse, enabling you to fade out the volume of a selected area.

Also See
- Clear
- Gain
- Normalize
- DC Offset
- Apply Effect
- Time Stretch
- Pitch Shift
- Track View
- Effects
- Editor
- Midi Editor
- Mixer
**Clear**

Clear simply clears a region of a clip so that no sound can be heard. This is handy if you have nasty clicks or noise at the start or end of your recordings.

Ensure that a selection is made prior to selecting this option.

**Gain**

The Gain option can be used to modify the volume of a sample by a specified amount. You can raise or lower the volume by a specified dB value or percentage.

Whilst in the Editor View, make a selection within the loaded sample then press the ‘Gain’ button. The 'Gain' window will now appear allowing you to specify a gain value. A value of 0dB would mean no gain at all (i.e. 100% of its original value). Positive values above 0 will increase the volume and negative values will decrease the volume.

If you wish to set the volume to be proportional to the maximum volume (i.e. 90% of full volume) then it is easier to use the ‘Normalize’ function rather than ‘Gain’.

**Normalize**

Normalise can be used to ensure all your clips are of similar volume. When this option is selected you will be asked to specify the maximum peak volume for your clip. The volume of your clip will then be adjusted accordingly.

Also See

Fade In/Out
DC Offset
Apply Effect
Time Stretch
Pitch Shift
Track View
Effects
Editor
Midi Editor
Mixer
**Apply Effect**

This option allows you to apply effects to a selected area of a clip. Tapping the ‘Apply Effect’ button will display the Apply Effects dialog. You can choose the required effect from the drop down menu at the top left of the dialog. Adjust the effect parameters as required and press the ‘Preview’ button to hear what it will sound like. Once you are satisfied with the results press the ‘Apply’ button or tap outside the dialog to dismiss it.

When applying effects such as delay, you might want to consider appending additional samples into your clip using the ‘Insert Silence’ option so there is room to render the decay trail.

**DC Offset**

DC offset is a nasty little component of many digital audio signals that, while often inaudible, can add to the noise floor of your project. At worst, DC offset can result in an audible ‘click’ on the beginning or end of an audio clip that has been edited.

You can see DC offset by zooming in on a view of a waveform. If the clips zero crossing line (the place where the waveform crosses from positive to negative voltage or vice versa) is actually not at zero, but higher or lower, you've got DC offset. If you hear clicks or experience low-level distortion you can check for DC offset by recording a few seconds of silence. If the resulting waveform appears above or below the zero line, there's probably DC offset.

Select ‘DC Offset’ from the ‘Process’ menu to remove the DC offset.

Also See
- Fade In/Out
- Time Stretch
- Pitch Shift
- Track View
- Effects
- Editor
- Midi Editor
- Mixer
**Pitch Shift**

This option allows you to retune samples by pitch shifting by a given number of semitones. Meteor will do its best to keep the length of the sample as near as possible to that of the original.

**Time Stretch**

Time Stretch is used to lengthen or shorten a recording without changing the pitch. This is handy if you have recorded clips and want to change your projects tempo from say 120 to 140 bpm (Beats Per Minute). This works well on small tempo changes but not so well in extreme cases. When using this option you can specify a change using time, tempo or beats and bars.

Also See
- Fade In/Out
- Clear
- Gain
- Normalize
- DC Offset
- Apply Effect
- Time Stretch
- Track View
- Effects
- Editor
- Midi Editor
- Mixer
**Mixer View**

The mixer is used to control both the master input and output volumes as well as individual track volumes, panning and effects levels. In general this can be used to control various aspects of both audio and MIDI tracks although care must be taken to ensure MIDI tracks have a MIDI Out channel assigned first.

![Mixer View](image)

**Pan Control**
Pan Control is used to position the sound either to the left or right speaker. On MIDI track Meteor sends controller CC-10 to the attached device.

**FX1-3 Controls**
Control the amount of each audio track which is to be sent to the 3 global Aux Send effect busses. When using MIDI tracks these options send CC controllers 91, 92 and 93 to your MIDI compatible device. These are usually mapped to effects such as Chorus and Reverb etc. on most keyboards.

**FXR1-3 Controls**
The knobs labelled FXR1-3 control the output level of the assigned Aux Send Effects of your effect rack.
**Track Fader**
This is used to adjust the volume of a particular track so that it sounds correct in the mix. If you hear distortion or clipping and a tracks peak meter to the left of the Fader is constantly in the red, try lowering the fader for that track.

You can use the track fader to send MIDI volume message CC-7 to the selected track on your MIDI keyboard. To use this feature make sure the MIDI Out channel is set to the correct MIDI channel you wish to control. If the Out channel is set to ‘Any’ then by default track 1’s fader will output to channel 1, track 2's fader will output to channel 2 and so on.

**Mute**
The ‘Mute’ buttons allow you to temporarily remove a track from the mix, you can mute as many tracks as you like.

**Solo**
The ‘Solo’ button enables you to preview a track in isolation. Selecting this button effectively mutes all other tracks that don’t have ‘Solo’ selected. You can solo more than one track at a time. Solo takes priority over mute, so if solo is selected on a particular track you will hear that track regardless of the start of the mute button.

**Master Volume**
The Master Volume section contains knobs for the left and right output volume. Reduce the master volume if the peak meters clipping lights are constantly flashing.

**Input Level**
The Input Level knob controls the level of the recording input which by default is the internal microphone.

**Arm**
The ‘Arm’ button is used to select the current record track.

**Effect Enable Buttons**
Each mixer track has a group of 4 Effect Enable buttons which allow you to quickly turn off Aux Send and Insert effects. The 3 green buttons labeled 1-3 allow you to toggle the 3 Aux Send effects on and off. The buttons are lit if the effect is enabled. The blue Insert Effects button lights if an Insert effect is enabled for that track. If the Insert effects are in a ‘frozen’ state then the button turns red. See [‘Freeze Insert FX’](#) for more information on this CPU saving feature.

**Track Names**
You can edit the Track Names via the ‘Edit Menu’, the names are displayed at the top of each track in the Mixer, giving you a quick a easy reference to what voice the track contains.
Effects Rack View

MeTeoR has 4 different methods of implementing effects, ‘Aux Send’, ‘Insert’, ‘Record’ and ‘Master’ Effects. The way in which you use these effects is totally down to personal choice but it is highly recommended that you use real time Insert effects sparingly as these can consume more CPU than Aux Send effects which are global and shared amongst all tracks and therefore more efficient.

Thankfully there is a way of using unlimited Insert effects without using any CPU at all, but you need to apply these after a track is recorded and finalized. See ‘Freeze Insert FX’ for more information on this feature.

To setup an effect press the ‘FX’ button on the Transport Panel, this will display the ‘Effects Assignment’ dialog, from which you can browse all available effects, and assign them to an effect bus.

You first need to select one of the four tabs, Aux Send, Insert, Record or Master depending on the type of bus you wish to make the assignment. Select the effect bus number 1-3 (1-2 in case of master effects), select the track 1-12 if you are assigning an Insert effect, then finally press the ‘Assign’ button.

You should now see the selected effect appear as the currently selected effect for that bus type and number. This is also reflected in the ‘Effects View’ tab which lists the effects and allows you to make modifications. You can’t actually change effects settings from the ‘Effects Assignment’ dialog, this has to be done from your effects rack in the ‘Effects View’ tab.

Please Note: Audio effects will have no effect on MIDI tracks or recorded MIDI data
**Aux Send Effects**

Aux Send Effects are used to route audio from selected tracks through a global set of shared stereo effect, which makes them more CPU friendly than other forms of effect.

You can define up to 3 global Aux Send effects including: Stereo Delay, Reverb and Chorus/Flanger.

To assign an effect to an Aux Send bus open the ‘Effects Assignment’ dialog by pressing the ‘FX’ button in the ‘Transport Panel’.

Select the ‘Aux Send’ tab then select an effect by scrolling through the list of available effects by swiping left to right. Select the ‘Aux Send’ bus numbered 1 to 3 then press the ‘Assign’ button. The effect will appear where the on screen instructions were previously displayed and will be made available in the ‘Effects Rack’ tab.

Also See:
- Insert Effects
- Record Effects
- Master Effects
- Delay
- Reverb
- Compressor
- Chorus/Flanger
- Mono Graphic Equalizer
- Distortion
- Tone Boost
- Side Chaining
**Insert Effects**

Insert effects apply to a single track. You can have up to 3 Insert effects on each track however due to CPU limitations you should use them sparingly or make use of Meteors ‘Freeze Insert FX’ feature in order to avoid overloading the CPU.

Insert Effects are mono and include delay, reverb, compressor, tone boost, chorus/flanger, noise gate, tremolo, graphic eq and distortion.

To assign an effect to an Insert bus open the ‘Effects Assignment’ dialog by pressing the ‘FX’ button in the ‘Transport Panel’.

Select the ‘Insert’ tab then select an effect by scrolling through the list of available effects by swiping left to right. Select the destination ‘track’ and ‘bus’ numbered 1 to 3 then press the ‘Assign’ button. The effect will appear where the on screen instructions where previously displayed and will be made available in your effects rack on the ‘Effects Rack’ tab.

Once you have assigned one of more Insert effects to a track, the Freeze Insert FX option will be made available. This is highly recommended as it re-renders a track with all the effects pre-applied so that it doesn’t place the burden on the CPU when it comes to playback.

Also See:
- Aux Send Effects
- Record Effects
- Master Effects
- Delay
- Reverb
- Compressor
- Chorus/Flanger
- Mono Graphic Equalizer
- Distortion
- Tone Boost
- Side Chaining
Record Effects

Record effects are useful for adding effects to your recordings rather than the effect being applied during playback. This saves on CPU load and frees up resources for other effects.

To assign an effect to a Record bus open the ‘Effects Assignment’ dialog by pressing the ‘FX’ button in the ‘Transport Panel’.

You can assign up to 3 effects for mono recording and another 3 for stereo track recording. Meteor will automatically select one set or the other depending on whether you have a mono or stereo track active. An active track is the one that is currently Armed.

Select the ‘Record’ tab then select an effect by scrolling through the list of available effects by swiping left to right. To assign an effect select the ‘Mono’ or ‘Stereo’ Input Type, select a record ‘bus’ numbered 1 to 3 then press the ‘Assign’ button. The effect will appear where the on screen instructions were previously displayed and will be made available in the ‘Effects Rack’ tab.

Note: If you are recording from a true stereo input into a stereo track you need to change the ‘Record Input Type’ to ‘True Stereo’ on the ‘Options’ menu.

Available Record Effects include: delay, reverb, compressor, tone boost, chorus / flanger, graphic eq, tremolo, noise gate and distortion.

Record Effects cannot by used on Stereo Tracks.
Master Effects

Master effects are used during the final mix-down stage of a song. You can assign up to two master effects which will affect the output of the mixer. Only certain effects such as compressor, reverb and graphic equalizers are suitable master effects.

To assign an effect to a Master bus open the ‘Effects Assignment’ dialog by pressing the ‘FX’ button in the ‘Transport Panel’.

Select the ‘Master’ tab then select an effect by scrolling through the list of available effects by swiping left to right. Select a record ‘bus’ numbered 1 to 2 then press the ‘Assign’ button. The effect will appear where the on screen instructions were previously displayed and will be made available in the ‘Effects Rack’ tab.

Also See:
- Aux Send Effects
- Insert Effects
- Record Effects
- Delay
- Reverb
- Compressor
- Chorus/Flanger
- Mono Graphic Equalizer
- Distortion
- Tone Boost
- Side Chaining
**Reverb**

Reverb is created when a sound is produced in an enclosed space causing a large number of echoes to build up and then slowly decay as the sound is absorbed by the walls and air. Think of the sound in a large room, cathedral or canyon, where you can't actually pick out the individual echoes. This is one of the most useful effects available for giving great depth to a sound.

There are two Reverb Effects available in Meteor, one mono and the other stereo. The stereo reverb is available for Aux Send and Master effects whilst the mono is available for use as Insert and Record effects.

The stereo reverb includes the option to turn the stereo imagery on or off, turning off will halve the CPU usage. This option is off by default.

The controls for the ‘Reverb’ are as follows:

- **Level:** Controls the input level to the effect. Adjust this level if the signal levels are peaking in the red or you can hear distortion.

- **Room Size:** Controls the length of time between reflections. the larger the value, the longer the reverberation trail.

- **Damping:** Controls the brightness of the reverb filter. It is pretty common to attenuate higher frequencies to enable a cleaner sounding effect. Cutting the higher frequencies ensures the original audio signal stands out from the reverberation trail. The higher this value, the higher the attenuation.

- **Width:** This option controls the stereo spread of the effect. Turn this up to maximum for full stereo separation.

- **Mix:** Controls the amount of the original signal is mixed with the effected signal. If the mix control is fully clockwise only the effected signal can be heard.
**Delay**

The delay or echo as it is often called is a great effect for adding depth and presence to a sound. As the name suggests it adds a series of echoes which slowly diminish over a specified period of time. The delay is an effect that can be synced to the metronome in order to create echoes which are in sync with the current tempo. If the tempo is adjusted via the metronome the delay time will adjust accordingly if the ‘Sync’ button is enabled.

Meteor has two types of delay, mono and stereo. The appropriate type is selected automatically depending on the bus type. Insert and Master effects are stereo, whereas Record and Insert effects are mono.

![Delay Effect](image)

Here are a list of ‘Delay’ parameters and their purpose:

**Input:** Controls the input level to the effect. Adjust this level if the signal levels are peaking in the red or you can hear distortion.

**Delay L:** Sets the delay in milliseconds of the left audio channel.

**Delay R:** Sets the delay in milliseconds of the right audio channel.

**Feedback:** Determines the number of repeats, the higher the number the more echoes.

**Mix:** Controls the amount of the original signal is mixed with the effected signal. If the mix control is fully clockwise only the effected signal can be heard.

**Sync:** If enabled the delay times are automatically adjusted by the metronome to sync with the current tempo.

**Left and Right Channel Sync Dividers:** Both left and right channels have a set of ‘Sync Divider’ buttons which control the channel delays if the 'Sync' button is pressed. A settings of ‘1:1’ will create an echo every beat, whilst a settings of ‘1:2’ will create an echo every half beat and so on.
**Chorus/Flanger**

A chorus effect is created by modulating a delayed copy of an audio signal with the original. This creates a natural thickening of the sound which is very pleasing to the ear.

![Chorus/Flanger Image](image)

**Presets:** Several presets are available from soft chorus effects through to extreme flanging. There are also a couple of Celeste settings which provide strange stereophonic detuned phasing effects.

The Settings in Chorus are as follows:

**Input:** Controls the input level to the effect. Adjust this level if the signal levels are peaking in the red or you can hear distortion.

**Speed:** This setting controls the speed of the LFO which modulates a delayed version of the input signal. The higher the value, the faster the sweep.

**Delay:** Sets the delay between the original and delayed input signal. The higher the value, the more noticeable the effect. This is what differentiates a chorus and flanger. Lower values typically create a flange type effect whilst higher values create chorus effects.

**Feedback:** Controls the amount of the output signal fed back into the input. Sometimes referred to as 'Regen', this is normally a flanger only parameter added to give a more drastic effects.

**Depth:** Controls the amount of modulation applied by the LFO. The bigger the value, the more noticeable the effect

**Mix:** Controls the amount of the original signal is mixed with the effected signal. If the mix control is fully clockwise only the effected signal can be heard.
**Distortion**

The Distortion effect is used to emulate various overdrive, fuzz, distortion and tube screamer type effects.

There are 8 distortion 'Modes', each providing a different and distinct distortion sound. Each has it's own set of filters which can be controlled using the 'Low', 'Medium' and 'High' tone controls.

Here are a list of 'Delay’ parameters and their purpose:

**Gain:** The gain controls the amount of distortion applied to the input signal. The higher the gain the more distorted the sound! Turning the gain up too much will result in unwanted feedback, especially when using headphones.

**Type:** Allows you to specify one of 8 emulations that can be used. Each setting has it's own unique filtering which allow you to emulate anything from simply overdrive to extreme distortion. Tone Controls: The 'Low', 'Mid' and 'High' knobs allow you to cut and boost low, mid and high frequency bands which are defined by the selected distortion 'Type'.

**Level:** Allows you to control the output level of the effect. As you increase the gain you may need to reduce the output level to either avoid feedback or reduce the possibility of overloading the input of effects further down the effect chain.

Please Note: If you use the distortion effect as an insert effect please ensure you are wearing headphones. Failure to do so may result in unwanted feedback which could be damaging to your ears at high volumes.

*NOTE: The Distortion effect is available as an In-App Purchase available from the ‘Online Shop’ which can be found on the ‘Help’ menu.*
**Graphic Equalizer**

A graphic equalizer is usually used in the final stages of a mix to cut or boost certain frequencies in a mix. The effect consists of two banks of 8 sliders for cutting and boosting assigned frequency bands. When a slider is centred at 0 then that frequency band is not affected. You can cut or boost each frequency band by +/- 12dB.

The graphic equalizer works in stereo when used as an Aux Send or Master effect, and mono when used as an Insert or Record effect.

![Graphic Equalizer Interface](image)

Here are a list of ‘Graphic Equalizer’ parameters and their purpose:

- **Input Level**: This allows you to attenuate the incoming signal to avoid clipping during the equalization phase. Reduce this setting if you hear any form of distortion taking place.

- **Output Level**: Allows you to reduce the output level after equalization. If you have boosted certain bands then you may wish to reduce the output signal level to avoid clipping.

Please Note: The graphic equalizer is quite a CPU intensive effect, so don't use more than one live compressor. Alternatively learn about the ability to Freeze Insert FX to free the load from the CPU.

*NOTE: The Compressor is available as an In-App Purchase available from the 'Online Shop' which can be found on the 'Help' menu.*
Compressor

The compressor is a useful tool to help reduce the dynamic range of an input signal by boosting low signals and attenuating high ones. Think of it as an automatic volume control. A compressor reduces the level of an audio signal if its amplitude exceeds a certain ‘Threshold’. The amount of gain reduction is determined by ‘Ratio’. A ratio of 4:1 means that if input level is 4 dB over the threshold, the output signal level will be reduced to 1 dB over the threshold (in other words the gain (level) has been reduced by 3 dB).

Here are a list of ‘Compressor’ parameters and their purpose:

**Knee:** The knee settings is used to control whether the bend in the response curve is a sharp angle or has a rounded edge which makes the attenuation less noticeable.

**Attack:** The ‘Attack’ phase is the period when the compressor is decreasing gain to reach the level that is determined by the ratio.

**Release:** The ‘Release’ phase is the period when the compressor is increasing gain to the level determined by the ratio, or, to zero dB, once the level has fallen below the threshold.

**Follow Peak:** This button switches between Peak and RMS sensing. When set to ‘Peak’ the compressor responds to the instantaneous level of the input signal. This provides tighter control, giving quicker changes in gain reduction. When set to RMS (default) the compressor allows a more relaxed compression that more closely relates to our perception of loudness.

**Mono/Stereo:** This selector determines if both left and right channels are treated independently or not. If the compressor is in stereo linking mode it applies the same amount of gain reduction to both the left and right channels.

**Output:** The 'Output' simply controls the level of the output signal. This is a way of ensuring an attenuated signal is boosted back to a satisfactory level.
**Side Chain:** Normally a compressor analyses the input audio and uses this to attenuate the same input. Side Chaining allows you to specify a controlling track which is used as a reference for the compression. This is typically used to create the pumping type effects found in dance music where a bass drum is used to create ducks and dives on sustained strings and vocals. Simply set the Side Chain Track to the one that contains the audio you wish to drive the compressor. This option is only available when the compressor is used as an Insert effect.

Please Note: The compressor is quite a CPU intensive effect so don’t use more than two simultaneous live compressors. Alternatively learn about the ability to Freeze Insert FX to free the load from the CPU.

*NOTE: The Compressor is available as an In-App Purchase available from the ‘Online Shop’ which can be found on the ‘Help’ menu.*
**Tone Boost**

The Tone Boost effect allows you to modify the Bass, Middle and Treble frequencies of a track.

![Tone Boost Effects](image)

Care must be taken when boosting the audio to avoid clipping. If the ‘Peak’ light is lit then the output signal is too loud and you should turn down either the 'Input' or 'Output' levels accordingly.

The options for the Tone Boost effect are as follow:

**Input:** This option is used to cut the input signal which can be useful if you are planning on boosting bass or treble.

**Bass:** Use this to cut/boost the low bass frequencies of the input signal. A value of 5 will give no boost, whilst higher and lower values will boost and cut respectively.

**Mid:** Use this to cut/boost the mid frequencies of the input signal. A value of 5 will give no boost, whilst higher and lower values will boost and cut respectively. It is often preferable to drop the ‘mid’ frequencies to emphasize the bass and treble rather than simply increasing the bass and treble which may result in clipping which introduces distortion.

**Treble:** Use this to cut/boost the high treble frequencies of the input signal. A value of 5 will give no boost, whilst higher and lower values will boost and cut respectively.

**Output:** Use this to cut the output level of the signal exiting the effect. You may need to reduce the output level if you boost bass, mid and treble excessively.

Please Note: This effect is a mono effect that is available as an Insert or Record effect. If you need more flexibility or want to add tone controls to a stereo bus then you should use the Graphic Equalizer instead.
**Side Chaining**

Side Chaining is a compression effect which is popular in dance / trance genres of popular music. It usually involves an audio compressor being driven by some external audio feed which controls the compressors 'gate' resulting in a pumping effect.

Say you have a bass drum on ‘Track 1’ and a string chord progression recorded on ‘Track 2’. Using Side Chain Compression you can dynamically adjust the volume of the strings when the bass drum sounds. As the bass drum sounds the volume of the strings is lowered. As the bass drum sound decays the strings volume is increased. This is how you achieve those ‘ducking and diving’ or ‘pumping’ effects.

To create this type of effect you need to add a compressor as an Insert effect to the strings (on track 2). You can do this using the ‘Effects Assignment’ dialog by pressing the ‘FX’ button on the ‘Transport Panel’.

Once a compressor has been assigned to the strings you need to go to the 'Effects Rack' tab and adjust the settings of the compressor. In particular you need to tell the compressor about the track you wish to use to control compression. You do this by setting 'Side Chain Track' option on the compressor itself. This option is only available when a compressor is added as an Insert effect. Simply tap on the option and select a track from the popup menu.

Finally you need to reduce the Attack approx 1ms and the Release to 10-50ms before adjusting the ‘Threshold’ until the desired effect is obtained.

Please Note: The compressor effect is an in-app purchase and can be purchased from the ‘Shop’ on the ‘Help’ menu. Side chaining is only available as an insert effect on Mono audio tracks.
**Noise Gate**

The noise gate can be used to eliminate unwanted background noise once you stop playing your guitar. You can control the level at which the noise gate kicks in using the threshold knob, the attack, release and hold control specify how quickly the noise gate is applied and removed, and the Range controls the amount of attenuation.

You should start by increasing the Threshold while not playing your guitar until the Gate light becomes illuminated. Now adjust the range so that it just manages to eliminate any unwanted noise. At this point you can play your guitar and adjust the Attack, Release and Hold settings as required.

The options for the noise gate are as follows:

- **Threshold**: Specifies the level measured in decibels at which the noise gate starts to attenuate the input signal.
- **Range**: Use this to determine the amount of attenuation when the noise gate is active.
- **Attack**: The amount of time measured in milliseconds for the noise gate to fade in the input signal once it rises above the threshold.
- **Release**: The amount of time in milliseconds for the noise gate to fade out the signal once it drops below the threshold.
- **Hold**: The time in milliseconds to hold the gate open before entering the release phase.

*NOTE: The Noise Gate is available as an In-App Purchase available from the ‘Online Shop’ which can be found on the ‘Help’.*
Tremolo

Tremolo is an effect that produces a rapid variation in the volume (amplitude) of a note or chord. The "Tremolo effect" should not be confused with the misleadingly-named "tremolo bar", a device on a guitar bridge which allows the player to create a vibrato or pitch-bending effect.

The tremolo is an effect that is able to ‘Sync’ with the Metronome in order to oscillate in time with the current tempo. If the tempo of the metronome is changed, this will also modify its oscillator speed so long as the ‘Sync’ button is enabled.

The Settings in the Tremolo Effect are as follows:

**Level**: Controls the input level to the effect. Adjust this level if the signal levels are peaking in the red or you can hear distortion.

**Speed**: Sets the speed at which the tremolo oscillates the volume level of the input signal.

**Mix**: Controls the amount of the original signal to be mixed with the effected signal. If the mix control is fully clockwise only the effected signal can be heard.

**Sync**: When enabled the tremolo syncs its oscillation with the current tempo.

**Sync Period**: Used in conjunction with the 'Sync' button, these buttons to specify how many oscillations occur per beat of the metronome. A settings of ‘1:1’ will create a full oscillation every beat, whilst a settings of ‘1:2’ will create a full oscillation every half beat and so on.

*NOTE: The Tremolo effect is available as an In-App Purchase available from the 'Online Shop’ which can be found on the ‘Help’ menu.*
Options Menu

There are a number of useful program options which are available on the 'Options' menu. Some of these are useful CPU savers which may come in useful if you are pushing the program to its limits.

Display Clip Descriptions

This option allows you to display a descriptive label on a clip so that you can more easily identify its contents. You can modify the label from the Audio Pool dialog. Turn this option off to reduce CPU load.

Display Clip Contents

This option allows you to turn off the drawing of waveform data on clips within the track view window. Turning this option off reduces the CPU load as it doesn't need to be constantly reading from file.

Record Monitor

This option is useful when recording clips. When enabled, sound from the audio input is routed through the record effects and back out of the speakers so that you can hear yourself playing along to pre-recorded tracks. Always wear a pair of headphones when using this feature otherwise you are likely to suffer unwanted feedback. Turn the Record Monitor off when you are not recording to reduce CPU load.

Record Input Type

Use this option to select the source audio channels for mono recordings. By default Meteor uses the internal microphone which is mono input in the left channel - ‘Left channel (internal mic)’. If you are recording onto a mono track from a stereo source then select ‘Merge Left+Right Channels’ so that both left and right channels are merged during recording. If you want to record to a stereo track from a stereo sound device then you should select ‘Pure Stereo’.

Follow Cursor

This option determines whether Meteor scrolls the screen to keep up with the play cursor. Turning this off prevents the screen from scrolling which in turn prevents the need to constantly update the clip contents.
Show VU Meters

This option turns off all the LED meters in the ‘Track’ and ‘Mixer’ views and is purely here to reduce CPU load.

Effect Processing

This is a quick and easy way of bypassing all audio effects. If you want to listen to your composition dry then this is easier than turning off the effects in the Mixer or on the Effect Rack view.

Send Controllers

This option turns off controller lane automation. Any volume, pan and effect level data placed on a tracks controller lane is ignored.

Memory Check

If Memory Check is enabled Meteor will constantly check the available free memory. If the amount of free memory drops to a dangerously low level you will be given a warning and the ability to do something about it. Turn this feature off if you don’t want to receive memory warnings. The Auto setting will work by checking the free memory and will automatically force other applications to close.

Latency

This option specifies the internal audio buffer size. A large buffer makes Meteor more tolerant of system interruptions and therefore reduces the chances of audio dropouts and glitches. Increasing the latency also increases the audible delay between the audio input and pre-recorded material when using 'Record Monitor' so use this option wisely! The default latency is Medium.

Auto Save

When enabled Meteor will automatically save your song after a period of time so long as editing has taken place.

Memory Usage

This option controls the amount of memory used by Meteor. By default this option is set to ‘Minimum Possible’ on the iPad 1 and ‘As Much As Required’ on the iPad 2. If this setting is set to ‘Minimum Possible’ then each TAB is unloaded when you move from one program area to the other. This does introduce a slight lag when accessing the Mixer or Effects tabs but ensures memory usage is kept as low as possible. Even iPad 2 users may want to use this option if multitasking several apps.
Enable FTP

This option enables and disables the inbuilt FTP server. Turn this off when not in use to save CPU load. See the section on Transferring Projects to a PC/MAC for more information on using this feature.
Effects - Phaser

Phasing is a technique used to filter a signal by creating a series of peaks and troughs in the frequency spectrum. The position of the peaks and troughs is typically modulated so that they vary over time, creating a sweeping effect.

Here are a list of “Phaser” parameters and their purpose:

**Level**: Controls the input level to the effect. Adjust this level if the signal levels are peaking in the red or you can hear distortion.

**Rate**: This controls the speed at which the LFO (low frequency oscillator) is modulating. The higher the value the faster the sweeping effect.

**Phase**: (Phaser 2 Only) Allows you to determine the point at which the LFO sweep starts, or sweep offset.

**Depth**: Specifies how far the LFO sweeps. The bigger the value the more noticeable the effect.

**Feedback**: This allows you to specify the amount of the effected signal that is fed back into the phaser. Sometimes referred to as 'Regen'.

**Mix**: Controls the amount of the original signal is mixed with the effected signal. If the mix control is fully clockwise only the effected signal can be heard.

**Stages**: (Phaser 2 Only) Is used to determine how many all-pass filters are used when creating the effect. The more filters used the bigger the intensity of the effect.

**Sync**: The sync button allows the phaser's speed to be synced with the metronome so that one complete sweep of the phaser's LFO is equivalent to either 1, 2 or 4 beats of the metronome, depending on the setting.

NOTE: The Phaser effect is available as an In-App Purchase available from the “Online Shop” which can be found on the “Help” menu.

Shop - In-App Purchases

The ‘Shop’ is where you can purchase additional functionality for Meteor such as new audio effects. The Shop is located on the ‘Help’ menu.
On entering the shop you should see a number of additional program features appear in the list box. You can view a description of these features by tapping on an item. If you have a bad internet connection or the items do not load you can press the ‘Refresh’ button.

To purchase a feature press the ‘Buy’ button. You will be prompted for your iTunes login details and once the purchase is confirmed you should see a tick appear next to the item you have purchased.

If you have had to restore your iPad and your In-App Purchases are missing you can press the ‘Restore Purchases’ button. This will fetch your original purchases from the iTunes store without incurring further charges. Make sure the account details you use are those with which you previously purchased the additional content otherwise it will not work.
The MIDI Editor

The MIDI editor is an Add-On which allows you to create and edit pre-recorded MIDI clips. It is available as an In-App Purchase which can be found in the ‘Shop’ on the ‘Help’ menu. The editor allows you to create and edit MIDI clips, modify and correct wrong notes using a piano roll view, add and edit controller data and perform advanced step recording amongst other things.

Once purchased a new tab will appear on the tab bar at the bottom of the display for easy access to the MIDI editor.

The editor comprises of a piano roll on the left of the display which can scroll to display all 128 midi notes. The edit area comprises horizontal color coded lines which represent the white and black notes on the keyboard.
At the top of the editor window is the MIDI Editor Toolbar which allows you to select the active track, the clip being edited, note length, MIDI Out Channel and the CC Controller to display.

There are also three tools to aid editing, the Pen Tool to add and resize notes, the Eraser Tool to remove notes and the Selection/Move Tool for selecting and moving groups of notes.

**MIDI Clips**

Each time you record on a MIDI track a MIDI clip is created which will contain all the notes for a recording session.

*Please Note:* If you begin recording and press the STOP button without playing any notes the clip will be automatically deleted.

Each clip is assigned an ID which will begin with an 'M' to denote MIDI followed by an incremental number. You can select a clip to edit in one of two ways:

a: by tapping and holding a clip in the Track View screen and selecting ‘Edit’ from the popup menu.

b: by selecting the Track and Clip ID from the MIDI Editor Toolbar.

**In-Place Editing**

By default the editor only shows a single clip which can be freely edited on the piano roll without fear of interfering with other clips on the timeline. If you want to edit the clip and also wish to see other clips for the selected track, enable ‘In-Place Editing’ from the ‘Edit’ menu.

When 'In-Place Editing' is enabled, you can see a ghosted version of other clips within the editor. You can quickly switch between active clips by tapping the ‘Clip Header’ in the Ruler. Tapping the Clip Header a second time is a convenient way of selecting all the notes in the clip.
**Creating MIDI Clips**

You can create new MIDI clips either by recording onto a track or using the ‘New Clip’ button to the left of the Ruler. Before you do so you need to mark the region which you want the clip will occupy by dragging a selection on the ruler. In other words if you want to create a new MIDI clip between bars 4 and 8, drag a selection on the ruler between bars 4 and 8 then press the ‘New Clip’ button. The newly created Clip Header will appear in the ruler area and the new ID will appear in the ‘Clip ID’ combo box.

![Image of a MIDI ruler with selection](image)

By default if you attempt to add a note to a MIDI track containing no clips one will be created for you automatically. There are times however when you may need to split notes over multiple clips so that they can be dragged around in Track View separately.

**Adding Notes To MIDI Clips**

You can add additional notes into a MIDI clip by selecting the ‘Pen’ tool in the MIDI Editor Toolbar. Now select the required note length from the 'Length' combo in the Toolbar. You should now be able to tap on the grid and lay a note. If you tap, hold and drag a magnifying glass will appear allowing you to accurately position the note. The magnifying glass is handy as it allows you to see what is under your finger, but you can turn this off if you wish. You can do this from the ‘View’ menu.

Notes added to a MIDI clip are assigned a MIDI channel number which can be set from the ‘Channel’ combo in the MIDI Editor Toolbar. By default MIDI data is transmitted back to the channel it originated if the Out Channel is set to ‘Any’. If a specific MIDI channel is specified then all data will be sent to that MIDI channel regardless of the channel it originated.

Notes can only be added to the active clip. To add or modify notes in other clips (when In-Place Editing is enabled) you need to tap in the clip header within the ruler to activate the clip.

**Changing Note Velocity**

You can change the note velocity of a note or group of notes quickly and easily by using the ‘Controller’ area under the piano roll. Ensure that ‘Note Velocity’ is selected in the ‘Controller’ combo in the MIDI Editor Toolbar, select the ‘Pen Tool’ to the left of the Controller window, tap and hold in the controller area then drag your fingers over the notes.

If you want to modify a single note of a chord, it might not be possible without first selecting the note on the piano roll. When a selection is made in the piano roll, only those selected note volumes can be modified.
**Resizing Notes**

You can modify the length of a note either by selecting one or more notes with the ‘Selection Tool’ and then choosing a new note length from the Toolbar or by selecting the ‘Pen’ Tool, tap on a note and drag a note to change its length. Dragging to the left decreases the note length, and to the right increases the note length. The length of the note will automatically snap to ‘Length’ intervals.

**Erasing One or More Notes**

You can erase notes one at a time using the ‘Eraser’ Tool or by dragging a selection around a group of notes using the ‘Selection Tool’ and selecting ‘Cut’ from the ‘Edit’ menu. If you make a mistake simply press the undo button.

**Scrubbing Notes**

Meteor has a facility that allows you to drag the cursor over a group of notes and hear how they sound. This is very handy when constructing MIDI clips from scratch in the editor or when making alterations to pre-recorded clips. To enable ‘Scrub’ mode, simply press the 'Loop' button to the left of the toolbar and it will toggle to ‘Scrub’ mode. In this mode you can simply drag your finger over the ruler in either direction and hear your notes ring out.

Another useful feature is the ability to tap on the piano roll to hear the pitch of a particular note. If the notes are a little too small you can change the size of the keyboard on the ‘View’ menu.
**Step Recording**

The are times when you might want to enter notes from your keyboard rather than blindly dropping notes into the MIDI editor. You can do this by activating ‘Step’ mode. Once in Step mode, select the ‘Length’ of note you wish to enter and set the ‘Quantise’ to the distance you wish to advance the play cursor after each note played. Meteor will pause before advancing the cursor after a note is detected. This gives you enough time to play a chord where all the notes aren't played at the exactly the same time.

**Solo A Track**

The ‘Solo’ button allows you to listen to a MIDI track in isolation from the rest of your song. Simply press the solo button on the extreme right of the toolbar. Press a second time to turn off solo mode.

**Modifying Controllers**

You can modify controllers such as pitch bend and modulation wheel etc. using the ‘Controller’ lane under the piano roll. This works in exactly the same manner as editing note velocities described earlier.

To begin you need to select a ‘Controller’ to edit using the combo box on the MIDI Editor Toolbar. The ‘Controller’ combo displays all the frequently used controllers and may not contain a specific controller you want to use. To add a controller to the list press the ‘Add’ button to the left of the controller lane. A menu of all the 128 available MIDI controllers will appear. Select the controller you wish to edit from this list and it will be added to the frequently used controllers list.

You can now use the controller tools to the left of the controller lane to add and remove controller data. Don't get the controller tools mixed up with the note editing tools.

On MIDI tracks Controllers are added to the MIDI clip itself, so you can only paint into the selected clip, and not outside its boundaries. You can extend a MIDI clip by dragging the tail of the MIDI clip header in the toolbar if you wish. It may be useful to enable ‘In-Place Editing’ if you need to edit controllers which span a group of clips.
**Controller Resolution**

Depending on the controller you are editing, you may need to paint a finer resolution for real-time manipulation of things such as Pitch Bend. You can do this by pressing the ‘Controller Resolution Button’ to the left of the controller lane. Keep in mind that adding too many controllers is not a good thing so use them sparingly, and use the course resolution where possible to prevent over saturation.

**Removing Controllers**

To remove controllers you can do so manually using the eraser tool to the left of the controller lane, or alternatively you can completely remove a particular controller type from a track by pressing the ‘Del’ button to the left of the controller lane. A popup menu will allow you to delete ALL controllers or the selected controller from a track.
Video Guide Pane

The video pane window is available as an in-app purchase. It allows you to import a video clip from your camera roll which can be used as a guide for your composition. This is especially useful when creating narrated compositions that need to be synced to video.

To use this feature select ‘Import Video’ from the ‘File’ menu. A dialog will appear allowing you to preview and select a clip to import. Once the clip is imported it will appear below the ‘Transport Panel’. Press the ‘Play’ button to begin playback of your project and the video will play in sync with your composition.

Selecting a position on the ruler will take you to the approximate position in the video window. This will not be 100% precise but will take you to the nearest key frame.

Press the ‘Close’ button to close the video window.

Also See

Your First Recording
Projects
Transport Panel
Track View
Editor
Mixer
Effects
Optimizing Performance

The following are suggested guidelines on how to get the best performance out of Meteor. Whilst some suggestions might be obvious, it is worth reading through this section if you need to squeeze that little bit more from your device.

Trimming Clips

It might seem practical to record a complete song in a single recording, but it doesn't actually make a lot of sense, both in terms of having to get everything correct in a single take and from a disk space point of view.

It is much better to split your song down into sections such as intro, verse, chorus, fill-in, ending etc. and simply record each section once. This way you can focus on making a perfect recording of a single passage rather than a complete song. To duplicate a chorus elsewhere in your song you can clone one or more clips and move into place, or drag the clip(s) out of the Audio Pool onto the stage, whichever you feel most comfortable with.

If you really must record a whole track in a single take, then we advise you to use the ‘Split;’ function to trim away sections where an instrument is not playing. This reduces the CPU overhead of effects processing and mixing for that part of a track. See the section on Splitting Clips for more information.

Use Effects Wisely

There is often a temptation to overuse effects without paying too much attention to how this affects performance. If you are hearing audio dropouts then this could be a case of you overworking the CPU. Ideally you should choose Aux Send effects over Insert effects for a number of reasons. First of all these effects are stereo, and secondly all 3 send busses are shared between all 12 tracks. This makes them far more efficient than using live Insert effects. If you really must use Insert effects it is best to make use of the Freeze Insert FX feature, although this can usually only be done once a track is completed.

You may also want to consider adding effects at the time of recording. You can do with Record effects. In order to hear record effects during recording you need to enable the ‘Record Monitor’ in the ‘Options’ menu. Please note that you should be wearing headphones when using this feature to avoid feedback.

Master effects are provided to allow extra effect processing to be added during a mixdown, to add extra compression or EQ to the mix. Using both Master effects at the same time as 3 Aux Send effects will most likely be pushing the iPad 1 over the edge, especially if you have more than 5-6 tracks of audio.
Other Tips

If you need to squeeze that little bit more processing power out of your device you might want to turn off a few program features in order to get the job done. These are a number of items listed in the Options menu such as turning off ‘Follow Cursor’ and ‘Display Clip Contents’ that should help you along.

Once you are finished recording you can increase the Latency setting in the ‘Options’ menu to help avoid audio dropouts during the mixing stage. A low latency setting is good for recording, but not so good for audio stability.

Always zoom out fully before starting a recording. Meteor caches a thumbnail of each clip which it uses to render audio data rather than having to build a thumbnail in real time from disk. This speeds up rendering considerably with zoomed out views. If you are zoomed in to any great extent Meteor has no alternative than to read data from disk each time a clip needs to be redrawn.

Finally, if you are finding the number of effects is causing CPU issues, you might need to consider performing a mixdown of your project. Please bear in mind that your exported song will not suffer this problem as it doesn't have to be rendered in real time.
Exporting Completed Songs

Mixdown

The Mixdown feature can be used to mix your entire song down to a single exported file, or to mix all tracks down to two mono tracks, one for the left and another for the right channels.

Exporting a Mixdown to WAV and CAF Files.

To export a finished mix of your song to an uncompressed WAV or compressed CAF file you need to select ‘Mixdown’ from the ‘File’ menu, then one of the ‘Mixdown to File’ options from the submenu. At this point you will be prompted for a file name to be used to save your exported file. The file will be saved in the 'Exported' folder of your iPad. You can retrieve exported file(s) for use on a desktop computer using the built in FTP client. See the section on Transfering your Project to your PC/Mac for more information on using FTP (file transfer protocol).

Mixing Down to 2 Tracks.

You may reach a point where all 12 tracks are used by imported / recorded clips and there is very little room to add new clips to the stage. One solution would be to mix all of your tracks down to two tracks which would represent the left and right channels of your song. This allows you to delete the original clips and free up ten tracks to begin again. This process is often referred to as 'bouncing' tracks.

To accomplish this you need to select the ‘Mixdown’ option from the ‘File’ menu, then 'Mixdown to 2 Tracks'. This will display a 'Mix Down' dialog allowing you to specify various options. You need to specify the destination for the left and right channel audio clips created during the mixdown, the default being tracks 11 and 12. If you are using any effects such as echo or reverb that fade away after the song ends you might wish to extend the padding which is essentially blank space appended to the end of your song.

You may also wish to select the option to remove all existing clips on all tracks if you don't mind loosing those. The original recordings will not be deleted from your audio pool.
**MIDI Setup**

The MIDI Setup dialog allows you to change various MIDI settings. By default MIDI is turned off but if you wish to record or play MIDI data then you need to enable MIDI using this dialog.

Before Meteor can record and play MIDI tracks you need to enable MIDI support which you can do by pressing the Enable MIDI button.

By default Meteor records data from ALL connected devices on ALL channels to the selected MIDI track. If you play back a recording then recorded MIDI data will be sent back to ALL connected devices. You may wish to change this and specify a specific device. You can do this by specifying the MIDI Out Device/Port in this dialog.

**MIDI Clock**

These settings allow Meteor to control the playback speed of an external sequencer. When Send MIDI Clock is enabled, Meteor will send 24 pulses per quarter note in order to manually step your sequencer and keep it in sync with Meteor. To use this feature you need to enable external sync on your MIDI hardware. When this option is enabled Meteor will also send MIDI Start and Stop messages to your sequencer.

Meteor can also send MIDI Song Position to your hardware sequencer. When enabled Meteor will send the current song position before sending a MIDI Start message when you press PLAY on the Transport Panel.

If Connect to Network Sessions is enabled, Meteor will send and receive MIDI data with other programs on your local area network that are mapped to the same network session. This option is disabled by default.

Meteor uses a built in delay compensation in order to keep MIDI and audio recordings in sync. However, there may be a slight latency introduced by your MIDI hardware. To account for this you can adjust the Delay Compensation slider. Typically this setting should be set to around +1ms, but can be adjusted to suite.
Virtual Instruments

Meteor now includes the ability to use internal virtual instruments as well as being able to send MIDI data to external equipment. You need to purchase the Virtual Instrument Pack from the Store before these options are made available and you must already own the MIDI editor in order to create MIDI sequences. The In-Apps are purchased from the Shop in the Help menu.

The Virtual Instrument Pack consists of 3 different instruments that can be attached to any MIDI track. You assign and remove instruments from a track using the Instrument button on the toolbar in the MIDI editor window.

![The Instrument Button](image)

The instrument pack contains the following instruments:

1) **Drum Machine**
2) **Analog Synthesizer**
3) **Sampler**

In order to help use the virtual instruments we have provided the ability to overlay a set of 12 Drum Pads or a Virtual Keyboard in the MIDI editor window. You can display these at any time by selecting either Drum Pads or Keyboard from the Split Screen View option on the View menu. These interfaces can be used during a recording session or using Step recording.

On tracks where no virtual instrument is assigned the Drum Pads and Virtual Keyboard send note on and off data to a connected MIDI device on the selected MIDI channel.

Follow these steps to add an Instrument to a track:
1) Select a Track from the selection box on the toolbar.
2) Press the Instrument button.
3) Select Assign Instrument from the popup menu.
4) Select the required instrument from the submenu menu.
5) Select a patch from the list of available patches.
To remove an Instrument:

1) Select a Track from the selection box on the toolbar.
2) Press the Instrument button
3) Select Remove Instrument from the popup menu.

To Edit an Instrument:

1) Select a Track from the selection box on the toolbar.
2) Press the Instrument button.
3) Select Edit Instruments from the popup menu.

If you experience any stuck notes when using Virtual Instruments you can select the All Notes Off option from the Instruments menu or press the STOP button on the transport panel.

Although there is no limit to the number of virtual instruments you can use, there might be occasions where you push for so many notes the program cannot cope. In these extreme cases you may hear sound breakups, crackles or pops etc. If you find yourself in this situation you can try using the Freeze FX button to render an instrument and any assigned Insert Effects which will help relieve the burden on the CPU. Any changes you make to a MIDI track whilst in its frozen state will not be heard until the track is unfrozen.

As a general rule stick to a maximum of 8 virtual instrument tracks and you should be fine so long as you don't push the polyphony too high. To help reduce CPU load you could also try turning off an instruments digital delay or the EQ on a drum kit. You can also try using only sampler patches that use only mono samples to reduce CPU load. In extreme cases try reducing the ADSR Release time to reduce the trail on notes and reduce polyphony.

To Change Patches:

Once an instrument has been assigned to a MIDI track you can switch patches in one of two ways:-

1: Open up the Instrument Edit window and use the patch menu.
2: Use the “Change Patch” option from the “Instrument Button” menu.

Downloadable Sound Libraries

Once the Virtual Instrument pack is installed you can access the “Downloadable Sound Libraries” option on the “Help” menu. Here you can download additional presets and sounds for your virtual instruments as and when they become available. Some of these libraries will be made available for free and help keep the size of the initial Meteor download and updates to a minimum.
Also See
Getting Started
Track View
Editor
Mixer
Effects
Audio Pool
Midi Editor
Drum Machine
Analog Synthesizer
Drum Kit Instrument

The Drum Kit instrument allows you to assign up to 12 audio samples to a set of drum pads which can be triggered via MIDI notes placed on a track in the MIDI editor, an external MIDI keyboard or Meteors Virtual Drum Pads.

In order to test a drum kit or aid playing the Drum Kit you can call up the Drum Pad overlay. When you assign a drum kit to a track the Drum Pads are displayed automatically, but you can display this window at any time by selecting the Drum Pads options from the Split Screen View option on the View menu.

Assigning a Drum Kit Instrument to a MIDI track

You assign instruments to a MIDI track using the Instrument button on the MIDI Editor toolbar. Pressing this button displays a popup menu allowing you to Assign, Remove and Edit an instrument to the selected track.

Follow these steps to add a Drum Kit to a track:

1) Select a “Track” from the selection box on the toolbar.
2) Press the “Instrument” button on the toolbar.
3) Select “Assign Instrument” from the popup menu.
4) Select Drum Kit from the submenu menu.
5) Select a patch from the list of available patches.

You can hear the drum sounds for the selected kit by either tapping on one of the 12 virtual drum pads or by playing the associated General MIDI key assigned to that key on an external keyboard.

Please Note: The text description on a drum pad refers to the General MIDI key it is assigned to and is not a description of the sample assigned to that pad. The Percussion kit contains some sounds for which there is no associated MIDI key in the general MIDI specification. In this situation the text refers simply to the MIDI key which triggers the sound.

Making Your Own Drum Kits

As with all our virtual instruments you are free to create your own drum kits and save them as patches which can be recalled and used for other songs. Drum kits are not stored as part of your project, but in a global folder which can be accessed from all your projects.

You can assign samples to each drum pad in one of three ways:
1) By dragging a sample from the Audio Pool directly onto a pad.
2) By loading a sample from a folder on your iPad.
3) By recording a sample directly onto a Pad.

To assign a previously recorded sample to a pad which is not in the Audio Pool tap and hold on one of the 12 pads and wait for an “Edit Pad” menu to appear. Choose “Assign Sample” and then “Import From File”. A file dialog will now appear allowing you to browse your device and select a sample to import.

![The Pad Edit Menu](image)

Alternatively you can choose “Record Sample” from the “Assign Sample” submenu and record your own sample directly onto a pad.

**Assigning a MIDI key to a Pad**

Once you have assigned a sound to a drum pad you need to specify which MIDI key is used to trigger the sound. The General MIDI specification sets aside a range of notes (35-81) to which drums can be assigned. Meteor allows you to assign a key by tapping and holding on a Pad until the “Edit Pad” menu appears. Now select “Assign GM Drum Note” and select one of the notes from the resulting list. A description of the note will now appear on the pad itself to remind you which note the sound is mapped to.

**Modifying a Drum Kit**

The “Edit Drumkit” window can be accessed via the “Instrument” button menu, on the MIDI Editor toolbar. This window allows you to modify the relative pad volumes and pan settings. You can also specify a master EQ setting and activate the Bit Cruncher which can be used to create lo-fi effects.
The Edit Drumkit Screen

Changes made to the mix of a drumkit are saved locally to your project rather than to the default drum patch. If you wish to save changes to the default drum patch press the “Save” button on the toolbar.

Please Note: You are free to Add and Remove drumkits using the “New Preset” and “Delete” buttons. You cannot delete or rename the “Default” preset. This is a special preset used when Meteor fails to locate a specific preset while loading your projects.

Also See
Getting Started
Track View
Editor
Mixer
Effects
Audio Pool
Midi Editor
Virtual Instruments
Analog Synthesizer
**Analog Synthesizer Instrument**

The Analog Synthesizer is a real time instrument that allows you to create unusual electronic type sounds that are difficult to create using the Sampler instrument. You can play notes on the synthesizer via MIDI notes placed on a track in the MIDI editor or via an external MIDI keyboard or Meteors own Virtual Piano Keyboard.

**Assigning the Analog Synthesizer Instrument to a MIDI track**

You assign instruments to a MIDI track using the “Instrument” button on the MIDI Editor toolbar. Pressing this button displays a popup menu allowing you to Assign, Remove and Edit an instrument to the selected track.

1) Select a “Track” from the selection box on the toolbar.
2) Press the “Instrument” button.
3) Select “Assign Instrument” from the popup menu.
4) Select “Analog Synthesizer” from the submenu menu.
5) Select a patch from the list of available patches.

When you assign an instance of the Analog Synthesizer instrument to a track the “Virtual Piano Keyboard” is displayed automatically, but you can display this window at any time by selecting the “Keyboard” options from the “Split Screen View” option on the “View” menu.
Changing Patches

You can change between the various patches by tapping on the patch name, to the right of the “New Preset” button at the top of the dialog. A list of patches will now appear from which to make your selection.

What is a Synthesizer

Whilst many of you will be content loading existing presets, there is great fun to be had creating your own unique patches or tweaking existing patches to suit your needs. Either way it is a good idea to know the basics about how a synthesizer works in order to get the most out of sound creation.

At the heart of any synthesizer is an oscillator which can produce a raw tone. The oscillator (or voltage controlled oscillator) is the building block of any sound, from which it is then sculpted and transformed into the final instrument. Meteor has two oscillators VCO1 and VCO2), and together they can produce a wide variety of tones. Once you have a basic tone it is passed to a voltage controlled filter or VCF for short. This shapes the harmonic content of a sound, giving a more natural sound by changing the frequency response over time. Imagine saying the vowels A,E,I,O,U maintaining a constant pitch for each vowel. We can still distinguish these letters by the harmonic content, despite being the same pitch. This is essentially what a voltage controlled filter does to a sound, it modifies the sound by filtering the audible frequencies contained within the raw base tone. To do this the VCF uses something called an envelope which defines the way in which frequencies are filtered over time. The envelope has 4 parameters, attack, decay, sustain and release, often referred to as an ADSR envelope. This envelope defines the filtering which is applied from the moment we trigger a note, to the moment we release the note and the sound dies away. Finally the sound is passed through a voltage controlled amplifier to control the actual volume envelope of the instrument. This amplifier is called VCA for short and uses the same ADSR envelope as used in the voltage controlled filter. If you think about a percussive instrument such as a drum, it creates sounds that hits full volume almost instantaneously, then dies away more slowly. A violin on the other hand has a slower attack which maintains a more uniform volume for the duration of a note.

Essentially what I have described are the basic workings of a synthesizer, with a few optional ingredients missing. Most synthesizers also have an LFO or low frequency oscillator which is used to add vibrato, tremelo or wah wah type effects to the overall sound. Essentially the LFO modulates various parameters of the VCO, VCF or VCA in order to achieve these effects.
VCO - Voltage Controlled Oscillator

The VCO is the starting point for sound creation as the oscillator produces a raw tone that dictates a sounds timber and quality. Meteor has a number of common building blocks available which include sine, square, saw, triangle as well as custom waves. Since Meteor's synthesizer has two oscillators it is possible to mix two completely different waves to produce sounds with far more complexity than you could with a single oscillator. Press the “WAVE” button to toggle between the various wave types.

In order to hear VCO 2 you need to ensure that it is enabled by pressing its “ENABLE” button. You will also need to ensure the “VCO1/VCO2” mix setting is roughly half way to hear a mix of both oscillators. VCO2 can also be detuned to create 5th and 7th octave shifts as well as creating octave harmonies. Use a combination of the “OCTAVE” button and “SEMI” (semitone) / “DETUNE” knobs to detune oscillator 2 as required.

Both VCO1 and VCO2 provide a form of Pulse Width Modulation or PWM for short. This is traditionally used with square waves to modulate the duty cycle of the wave, but may give interesting results with other waves too. PWM gives a chorus type sound, which is useful for thickening up a sound.

VCO1 has a custom wave feature which can be used to create more complex waveforms. Pressing the “CUSTOM” button displays the Custom Waveform screen allowing you to overlay harmonics over a sine wave to produce some interesting sound combinations. Careful use of the custom wave feature can result in organ or string type tones.

VCO1 has a unique option called “SUBOSC” which should be used with caution. This knob controls the number of simultaneous oscillators that are used to create a single note. Settings this to 4 whilst using SAW or SQUARE waves will produce thick string type sounds but is extremely expensive in terms of CPU. If you want to use this feature try and limit the polyphony or even better select MONO mode.

VCF - Voltage Controlled Filter

The VCF is used to shape the harmonic content of a sound over time. The content is controlled by an ADSR envelope which is triggered when a note is played and is used to control the frequency content up until the moment the note is released and the sound dies away.

The “CUTOFF” frequency is used to set the base frequency of the ADSR envelope, and the “RES” (resonance or Q) controls the harmonic content. “ENV-AMT” (or envelope amount) dictates the weight of the envelope on the cutoff frequency. Positive values of “ENV-AMT” make the frequency envelope rise when a key is pressed, whilst negative values make the frequency envelope fall.

There are three different types of filter, HP (high pass), LP (low pass) and BP (band pass) filters available. Press the “FILTER” button to change the filter type.
VCA - Voltage Controlled Amplifier

The VCA is responsible for controlling the overall volume level of the instrument, from the moment a key is pressed to the time the key is released and the sound fades away. The VCA uses an ADSR envelope in order to specify how this occurs and the length of an individual note.

ADSR - Envelopes

Both the VCF and the VCO components use ADSR envelopes to control cutoff frequency and volume respectively. ADSR stands for Attack, Decay, Sustain and Release.

**Attack:** Specifies the amount of time it takes before a sample reaches full volume. Think of it as a fade in which is quite useful for string sounds.

**Decay:** Sets the amount of time taken for the sound to die away from its peak to the sustained level.

**Sustain:** This is the volume level which is maintained after the initial peak and decay have occurred. This is maintained until you lift your finger and the note stops.

**Release:** This describes the amount of time taken for a sound to die away from its sustained level when a key is depressed.

LFO - Low Frequency Oscillator

LFO stands for Low Frequency Oscillator, and is essentially a very slow sine wave used to manipulate the sound in pleasurable ways. The LFO is responsible for producing effects such as vibrato, tremolo and wahwah.

**Speed:** The speed of the oscillator.
**Attack:** How quickly the effect is applied to the voice.
**Vibrato:** The amount of vibrato, which is essentially a fluctuation in pitch.
**Tremolo:** The amount of tremolo which is a fluctuation in volume level.
**WahWah:** The amount of modulation applied to the VCF's cutoff frequency.

**Wave Type:** You can choose between four different types of oscillator, each giving it's own unique sound (sine, square, triangle and random).

MIX Settings

The MIX settings are used to control volume levels of the two oscillators, random noise generator, patch volume, portamento and digital delay.

**VCO1/VCO2:** This knob controls the volume balance of VCO1 and VCO2. If this knob is turned all the way to the left (-64) then only VCO1 can be heard. If this setting is all the way to the right (64) then only VCO2 will be heard (if VCO2 is enabled). A value of 0 represents equal levels of VCO1 and VCO2.

**NOISE:** Controls the mix of the VCO's and the random noise generator. A value of 0 turns off the random noise generator, whilst a value of 64 would turn off the VCO's.

**LEVEL:** Controls the volume level of the patch.
PORTA: Portamento is used to control the time taken to sweep or glide from one note to another.

DELAY: Sets the mix level of the digital delay in relation to the dry signal. The digital delay needs to be enabled for this to have any effect.

Digital Delay

The digital delay adds a nice stereo echo to your sound making it feel more spacious and adding separation to the sound. Be sure to enable the delay by pressing the “ON” button and ensure the “DELAY” level in the “Mix” settings is turned up before adjusting the delay settings.

Delay L & Delay R: Use these knobs to specify the left and right delay between echo repeats.

Feedback L & R: Used to set how quickly the effect dies away for both left and right channels. A high feedback setting will result in a longer echo trail (i.e more repeats).

Saving Patches

After creating a new patch it is important to save your changes using the “Save” button. This will overwrite any existing patch of the same name with any changes you have made in the Analog Synthesizer Edit dialog.

It is important to remember that these patches are global, so any changes made to these patches will effect all songs that rely on a patch. You can make minor tweaks to the ADSR and Digital Delay settings without the need to Save the patch and therefore make the settings permanent. Instead these patch modifications are saved as part of your project settings, and are restored when a project is loaded.

Please Note: You are free to Add and Remove patches using the “New Preset” and “Delete” buttons. You cannot delete or rename the “Default” preset. This is a special preset used when Meteor fails to locate a specific preset while loading your projects.

There is a maximum polyphony of 16 notes per instance of the Analog Synthesizer. Increasing the SUBOSC settings has no effect on the number of individual notes that can be played.

Also See
Getting Started
Track View
Editor
Mixer
Effects
Audio Pool
Midi Editor
Virtual Instruments
Drum Kit Instrument
**Sampler Instrument**

The sampler is an instrument that allows you to trigger one or more sound samples layered over a 6 octave keyboard. These samples can be triggered via MIDI notes placed on a track in the MIDI editor or via an external MIDI keyboard or Meteors own Virtual Piano Keyboard.

**Assigning a Sampler Instrument to a MIDI track**

You assign instruments to a MIDI track using the “Instrument” button on the MIDI Editor toolbar. Pressing this button displays a popup menu allowing you to Assign, Remove and Edit an instrument to the selected track.

![The Instrument Button](image)

Follow these steps to add a Sampler to a track:

1) Select a “Track” from the selection box on the toolbar.
2) Press the “Instrument” button.
3) Select “Assign Instrument” from the popup menu.
4) Select “Sampler” from the submenu menu.
5) Select a patch from the list of available patches.

When you assign a Sampler to a track the “Virtual Piano Keyboard” is displayed automatically, but you can display this window at any time by selecting the “Keyboard” options from the “Split Screen View” option on the “View” menu.

![The Sampler Instrument](image)
Changing Patches

You can change between the various patches by tapping on the patch name, to the right of the “New Preset” button at the top of the dialog. A list of patches will now appear from which to make your selection.

Creating Your Own Patches

Meteor allows you to create your own presets based on existing samples or by sampling your own sounds from scratch. Pressing the “New Patch” button allows you to specify a name for the new patch. Type in the name of your new patch and press “Ok”. Once a new patch is created you need to add one or more samples by pressing the “Add” button below the sample list. You can either import a sample from file or record one directly using the “Record Sample” dialog.

Once you have assigned a sample you need to specify the root note and range of keys that this sample can be triggered by. The “Root” note is simply the physical note which was recorded to produce the sample. This is used to determine how the sample is pitch shifted and must be set correctly for your instrument to be in tune. The active key range for each imported sample can be specified using the “Start” and “End” buttons. Most instruments will consist of one sample per octave range on the keyboard.

Setting Loop Points

Some instruments such as a guitar or piano create notes which naturally reduce in intensity over time. Other instruments such as an organ or violin have sustained notes which sound until the musician stops playing a note. In such cases it would not be wise to record a sustained note of 30-40 seconds since the resulting audio sample would be huge. You can effectively loop such sounds so that they repeats themselves every couple of seconds to produce a convincing sustained note and reduce the sample size.

Press the “Loop Mode” button to turn on loop mode. You should see a ghosted area appear in the sample preview window with start and end loop markers at either end of this ghosted area. You can move the start and end markers by dragging with your finger to a new location. Ideally you should set your loop start point at the point you want the repetition to occur and the end loop point somewhere near the end of the note. It's exact position depends on what sounds good to the naked ear and might take some experimentation in order to avoid pops and clicks as the sample loops. Use the virtual piano keyboard to test out the samples and ensure each sample in your patch is looped correctly.

To help reduce pops and crackles as the sample loops we have added a “CrossFade” feature which when enabled will fade between the start and end loop locations in order to obtain smoother sounding transitions.
Normalizing Samples

If your custom drum kits contain samples obtained from different sources then the chances are that they will all have different volume levels. You could simply change the “Sample Volume” level of each sample but if one sample is excessively low you would end up turning down the volume of other samples to compensate, resulting in a patch with no punch. To resolve this you can use the “Normalize” button which will attempt to boost a samples volume level so that all samples in your instrument are approximately equal.

ADSR Settings

ADSR stands for Attack, Decay, Sustain and Release and these settings define a volume envelope that is assigned to your patch.

**Attack:** Specifies the amount of time it takes before a sample reaches full volume. Think of it as a fade in which is quite useful for string sounds.

**Decay:** Sets the amount of time taken for the sound to die away from its peak to the sustained level.

**Sustain:** This is the volume level which is maintained after the initial peak and decay have occurred. This is maintained until you lift your finger and the note stop.

**Release:** This describes the amount of time taken for a sound to die away from its sustained level when a key is depressed.

Digital Delay

The digital delay adds a nice stereo echo to your sound making it sound more spacious and adding separation to the sound, especially when using MONO samples. Be sure to enable the delay by pressing the “DELAY” button in the “Mix” settings before adjusting the delay settings

**Delay L & Delay R:** These specify the left and right delay between echo repeats.

**Feedback:** Can be used to set how quickly the repeats die away. A high feedback setting will result in a longer echo trail.

**Mix:** Can be used to set the volume level of the echo with respect to the original sound.
Saving Patches

After creating a new patch is important to save your changes using the “Save” button. This will overwrite the original patch with any changes you have made in the Sampler Edit dialog and any samples assigned to the patch.

It is important to remember that Sampler patches are global, so any major changes made to these patches will effect all songs that rely on a patch. You can make minor tweaks to the ADSR and Digital Delay settings without the need to Save the patch and make the settings permanent. Instead these patch modifications are saved as part of your project settings, and are restored when a project is loaded.

*Please Note:* You are free to Add and Remove patches using the “New Preset” and “Delete” buttons. You cannot delete or rename the “Default” preset. This is a special preset used when Meteor fails to locate a specific preset while loading your projects.

Due to the sheer physical size of the sampler patches, we have to ship Meteor with a limited set of patches in order to keep the download size from getting too large. Although we have attempted to cover most of the musical categories we will be making other instrument packs available shortly, some of which will be available for free on our website and others which will be available as In-App purchases.

Also See
- Getting Started
- Track View
- Editor
- Mixer
- Effects
- Audio Pool
- Midi Editor
- Virtual Instruments
- Drum Kit Instrument
- Analog Synthesizer
Record Sample

The Record Sample dialog is used to record your own samples for use with the inbuilt virtual instruments, in particular the Sampler and DrumKit instruments.

Accessing this dialog from the Sampler Instruments “ADD” button displays the following options:

Since the Sampler Instrument allows you to assign multiple overlapping samples across a 6 octave range of keys we provide some simple options which will allow you to assign up to 8 samples to a patch without leaving the record dialog. These options appear along the top of the window, Set Range, Root Note, Start Note and End Note.

Set Range: This button allows you to quickly set the Root Note, Start Note and End Note in a single stroke without having to manually set each option. In general you will want to assign a single sample to the entire keyboard or several samples spanning an octave each. You can do this by simply selecting the required option from this menu and start recording.

Root Note: This refers to the actual note being recorded. If you are recording a middle C, select C4 from this menu. This tells Meteor how to pitch shift the note when playing other notes using this sample.

Start Note: This is the start of the key range which activates this sample

End Note: This is the end of the key range which activates this sample

Recording a Sample

The first thing you need to do is ensure that whatever you are recording is registering on the peak meter. When there is complete silence you should see only one or two segments of the meter lit until you play a note.

Set the trigger level so that the two white trigger markers are hovering one segment above the level of the background noise. Recording only begins when Meteor picks up an audio level higher than the trigger level.
Press the “REC” button and the recording light will flash repeatedly until you press a key and recording starts. Whilst recording the recording light will stop flashing and remain ON until recording is stopped.

Recording stops by either pressing the “STOP” button or when the “AUTO STOP” button is enabled and the recording level drops significantly. If the recording stops too early, disable the “AUTO STOP” option and manually stop the recording yourself.

Please Note: There is a 10 second limit on the length of samples recorded using this method.

**Inserting a Recorded Sample into the Patch**

Once you are happy with your recording you can assign it to a range of keys in the Sampler Instrument. First you need to ensure the Root Note matches the frequency of the recorded sample and that the Start Note and End Note correspond to the range of notes you want to assign the sample. As discussed earlier the “Set Range” button can be used to simplify this operation.

Finally press the “INSERT” button to assign the sample to the patch.

**Recording Samples for Drumkits**

The Record Sample window can also be accessed from the “Pad Options” popup menu of a drum pad (see Drum Kit Instrument for more information). This allows you to record a set of samples which can be assigned to specified pads without the need to close the window. The only difference between recording samples for the Sampler and Drumkit Instruments is the way samples are assigned. In the case of the Drumkit, you assign a sample to one of the 12 pads rather than a range of keys. You also need to specify a MIDI note which is the General MIDI note to which the pad is assigned.

Please Note: A MIDI note can only be assigned to a single drum pad. If you attempt to assign a MIDI note to a pad and that MIDI note is already assigned to another pad an error will be displayed.

Also See
- Getting Started
- Track View
- Editor
- Mixer
- Effects
- Audio Pool
- Midi Editor
- Virtual Instruments
- Drum Kit Instrument
- Analog Synthesizer
Troubleshooting

Meteor not Running

If Meteor is behaving erratically or exiting unexpectedly you might be suffering from lack of physical memory. The iPad has only 256Mb of memory of which only 100Mb is available to share with other running applications (once the OS steals its share). The Safari and Mail applications can soon consume the remainder if running so in situations like this it is a good idea to exit these and other none essential apps.

To do this double tap the HOME button to display the task manager. This contains a list of running programs. Tap and hold an icon for 3-5 seconds until all the icons in the task manager start to wiggle. A small close icon also appears in the top left of each program icon. Tap the close icon to unload each program in turn then finally press the home button to return to the home screen.

If problems persist then try powering off your device by holding the ‘power’ button for 5 seconds then, slide to power off. Wait 10 seconds then power back on again. This reboot procedure will ensure that all memory is returned to the system and Meteor is the only program running.

Audio Stuttering

Meteor is a very demanding product which will attempt to squeeze every bit of processing power it can and then some! If you suffer from audio glitches or dropouts it is almost certainly due to other applications such as Safari or the Mail application hard at work trying to disrupt you. In these cases we suggest you double tap the ‘home’ button to bring up the task manager and shut down as many programs as you can (as described above).

If you are still suffering audio glitches after you have unloaded all other running programs and performed a power off and on again your problem may be due to pushing the program too hard with audio effects. Please read the section on Getting Started to get an idea of what is possible and what is not. In particular learn how to make use of the ‘Freeze Insert FX‘ options.

You may also want to try increasing the latency setting found in the ‘Options’ menu. By increasing the latency you are increasing the size of the internal mixer buffer which allows Meteor to be more tolerant of system interruptions. This can introduce a slight lag when listening to live input using the Record Monitor, but should have no effect on actual recordings. Using the ‘Low’ latency settings might be great for real time recording, but it can cause issues if you have many clips starting at the same time during playback. In extreme cases it can cause a clicking or momentary pause. If possible, avoid this setting on large projects or when using many effects.
**I Can't Hear Any Effects**

After assigning effects to your effect rack they are automatically powered on (i.e. the red power button is lit) but you may have turned them off at some time.

Insert effects are automatically enabled in the mixer, but Aux Send effects are not because they are global and can be applied to any track. For this reason you need to manually enable these effects on a specific channel using the blue enable buttons labelled 1-3 in the mixer. Modifying a send effect knob FX1-3 in the mixer will automatically enable the effect if it not already enabled.

Record effects can only be heard once a track has been recorded and is being played back, unless you have ‘Record Monitor’ enabled. When enabled you can preview the effects prior to recording.

**FTP Transfer Problems**

In order to use Meteors FTP server your iPad must be connected to a router via Wifi and not simply connected to the internet via a mobile service provider. In other words you router needs to allocate you an IP address on your local area network.

FTP transfer is more reliable if you set your FTP packages ‘Maximum Simultaneous Transfers’ to 1. This option can be found in FileZilla Settings dialog under ‘Transfers’.

See [Transfer your Project to your PC/Mac](#) for more detailed information on using FTP.

**Feedback Problems**

If you are suffering feedback issues at moderate to high volumes then chances are you have ‘Record Monitor’ enabled. This option should only be enabled if you are wearing headphones, as it passes audio input from the microphone directly to the speaker for monitoring purposes. To turn off this feature select ‘Record Monitor’ from the ‘Options’ menu then select ‘Off’.

The distortion effect can also cause unwanted feedback if used with the record monitor. At times, especially when recording with the distortion effect as a ‘Record Effect’ the only solution is to lower the master volume and wear headphones. The distortion effect itself is artificially amplifying the input to the point of clipping to produce the distortion effect. The iRig adapter is known to cause a certain amount of internal feedback. Other solutions such as the AmpKit adaptor are less prone to this kind of problem. The only way to totally eliminate the issue is using a supported USB sound card.
**Muting Tracks Doesn't Reduce CPU Load**

You may find if you have assigned too many effects to your project things will begin to slow down to the point it actually causes audio glitches during playback. At this point you might try and mute tracks in the hope that this helps reduce the CPU load, but unfortunately this will not help matters! Meteor still processes data and effects for muted tracks so that you can drop in and out of the mix without sync issues. Consider a delay which is linked to the tempo of the metronome. It needs to keep in sync in order to resume correctly when the track is unmuted. One way around this is to mute the actual effects by pressing the POWER button on the effects in question from the Effects rack view. Alternatively you can temporarily turn off all effects processing by selecting ‘Effect Processing -> Off’ option from the ‘Options’ menu.

1 Keep Losing My Mix Settings!

This problem is most likely due to the fact you have entered automation data into a controller lane which is changing volume, pan or effect send levels on the fly. Try turning off controllers using the ‘Controllers’ option on the ‘Options’ menu and see if that helps. See the section on the Controller Lane for more information.

**The Mixer isn't working correctly with MIDI tracks!**

It is important to ensure you set the correct MIDI Out channel for each track rather than leaving them as ‘Any’ which is the default. If a MIDI tracks Out channel is set to ‘Any’ then track 1 will send volume and pan CC's to channel 1, track 2 will send CC’s to channel 2 and so on. If a specific MIDI channel is set, volume and pan will be sent to the designated channel

**I am getting no MIDI input from my keyboard!**

You need to ensure that MIDI is enabled in the ‘MIDI Setup’ dialog in the ‘Options’ menu. You also need to change a ‘Track Type’ to MIDI in the tracks controller lane. The controller lane can be viewed by double tapping on a tracks ARM button.
**I am having problems MIDI with Stuck Notes!**

During testing we tried using many different MIDI interfaces and MIDI keyboards so we know the program functions correctly in all situations. However, we did find that some interfaces are better than others, and in certain situations we have seen dropped notes, however this is a hardware and not a software issue. You will most likely find that other iOS software suffers the same problem. Of all the interfaces we tested, the most reliable seem to be those that use the camera connection kit. If you need a reliable interface to use with the connection kit we recommend the E-MU midiTab 1x1 interface which is a reliable and cheap interface which has been extensively tested.

The Alesis IO Dock is known to have problems with both MIDI (stuck notes) and recording audio (clicking audio). This is a general problem which effects all application and is currently being investigated by Alesis. The dock works fine some of the time, just not consistently.

**I cannot get my MIDI interface to work**

Your MIDI interface needs to be compatible with the iPad and coreMIDI. If you are connecting via the camera kit adapter then your interface needs to be low powered or self powered and require no drivers in order to work correctly. The E-MU midiTab 1x1 interface is an example of a MIDI interface that works perfectly with this software.

Also See
- Your First Recording
- Projects
- Transport Panel
- Track View
- Editor
- Mixer
- Effects
What's New in Meteor v1.2

This version of Meteor introduces virtual instruments. You can purchase the Virtual Instrument pack via an In-App purchase from the “Store” on the “Help” menu. The virtual instrument pack requires the MIDI editor plugin in order to operate but allows you to assign Drum Kits, Analog Synthesizer or Stereo Sampler instruments to MIDI tracks. To help conserve CPU virtual instruments can be frozen along with any assigned insert effects.

A Stereo Phaser Plugin has been added to the In-App purchases

Side chaining is now available on Stereo audio tracks using the Compressor.

MIDI Thru support has been added to the MIDI Setup page

Virtual Piano Keyboard and Key Pad windows now available in the MIDI Editor for use with real time recording and step recording.

A new option has been added to the Mixdown menu allowing you to export each track individually during a mixdown. This is useful for transferring your projects to other packages.

What's New in Meteor v1.1

This version of Meteor has lots of new features which have essentially required a major re-write of the program. Here is a list of the new features which are now available.

Stereo Recording and Stereo Tracks

Meteor now supports recording of stereo tracks, as well as importing and editing of stereo audio data. All file imports and PasteBoard options now prompt the user if they wish to import mono or stereo files, and in some cases gives the option to split the file into two mono samples.

To find out more about stereo recording please read the following sections:

Track Types
Your First Recording

MIDI Tracks and MIDI Recording

This version of Meteor introduces MIDI tracks allowing MIDI recording and playback. You can now connect up an external keyboard (or other MIDI hardware) and record your virtuoso performance directly into Meteor. Once recorded you can edit and play your recordings back to your MIDI equipment.

NOTE: By MIDI we don't mean virtual instruments, just the ability to record and play data from MIDI compatible hardware. You may also require an iPad compatible MIDI adapter and camera kit adapter in order to do this.
To find out more on MIDI recording please read the following sections:

**Track Types**
**Midi Recording**
**Troubleshooting**

We were originally going to provide this MIDI functionality as an In-App purchase as we know it might not appeal to everybody. However we didn't want people to miss out on the opportunity to delve into the wonders of MIDI. You can freely record and play MIDI tracks, and perform basic functions such as splicing and merging MIDI clips, as well as a Quantise function.

We have also provided a MIDI Editor as an In-App purchase for those wanting more control over editing. This editor features step recording, controller editing, note scrubbing, In-Place Editing and much more.

For more information on the MIDI Editor see:

**Midi Editor**

**Stereo Effects**

All Meteors effects have been upgraded to support stereo in and out. This allows you to use stereo Record and Insert effects just like you did previously with MONO tracks. The only exception is Side Chaining which can only be used with MONO tracks.

**Memory Usage**

We have added a new option to Meteors “Options” menu called “Memory Usage” which has two settings. The “Minimal-Minimum Possible” setting tells Meteor to unload each TAB as you move from one program area to the other. This results in Meteor using only half the memory of previous versions, but results in having to load each TAB as you move from say “Track View” to “Mixer View” etc. The “Optimum-As Much As Required” setting tells Meteor to work the same way as in old versions of the program.

We have also significantly reduced the amount of memory used during PasteBoard operations which should make the program more tolerant of other multi-tasking applications.

**Other New Features**

Here is a list of some other useful features we have added to this version of Meteor:

The ability to specify clip colors as well as track colors. This allows you to color an entire chorus differently from a verse etc. This option can be found on Track Views “Edit” and is called “Assign Clip Color”.

Stereo PasteBoard Imports and Exports.
Cross Fading of Audio Clips. You no longer need to use volume controllers to get the perfect fades. Now you can add non destructive fades to an audio clip quickly and easily.

Paste At Cursor. This option will appeal to anyone wanting to import samples from other packages into Meteor using the PasteBoard. You can now simply ARM a track, place the play cursor then choose “Paste At Cursor” from the “Edit->PasteBoard” submenu. Meteor will automatically convert the pasted data to the correct number of channels and insert the sample into the Track View.

Split Stereo Channels. This new Audio Pool option allows you to split stereo recordings so that you can pass each channel through separate effects using MONO tracks.

Fine, Medium and Course Controller resolutions are now available. This allows more precise fades and editing of MIDI data such as Pitch Bend.

Track Names can now be assigned to the Mixer view to help distinguish various instruments tracks.

The Mixer now supports sending of MIDI CC messages to a connected keyboard to control volume and pan etc. of MIDI tracks.

Improved selection in the Sample Editor. You can now drag the start and end selection points.

Improved MixDown which now mixes your song down to a single stereo channel.

Added Drop Shadow once clips are in MOVE mode.

Also See
- Your First Recording
- Projects
- Transport Panel
- Track View
- Editor
- Mixer
- Effects